Publish Library in Orchestrator

Hi everybody,
I’m starting the development of a brand new project with UIPath. I’m trying to publish my library on the orchestrator, but that option is disabled in the publishment options window. Do you know why? Could you help me please?
Thank you very much.
JBaers

Hi @JBaers

You have to make sure that your Developer machine is connected to Orchestrator via the Robot. Please see here for more info:

@JBaers currently the option to publish a library to UiPath’s Community Orchestrator is not available - only for on-premise setups. Please see #BetaFollow-up - Library (Reusable components) for more information on library usage.

2 Likes

Ok, thank you for your responses…

1 Like

Hi @Cyril_Kuhns, Do we have this option now to publish library from Community edition Studio and Orchestrator?

Hi @ankit002

Yes, you can now publish your Libraries to the Orchestrator instance on platform.uipath.com :slight_smile:

Thanks for your response @loginerror.

My robot is connected to Orchestrator and I’m able to publish projects. However when am trying to publish a library I’m getting the following error: “The Orchestrator version does not support upload for library project or upload is disabled for Orchestrator for this project type.”

Also, another problem am facing is that I’m not getting Libraries page in my Orchestrator.

Can you please guide me how can i make it work? Am sure am using the latest version of Studio(Community edition) and Orchestrator {will share the exact version when am near my laptop}.

I’m using the Orchestrator on cloud: https://cloud.uipath.com and not platform.uipath.com if that makes a difference.

Thanks in advance.

Please use https://platform.uipath.com/yourCloudAccount/yourOrchestratorInstance

The other link is the same thing, but might malfunction :slight_smile: (the forwards are sometimes causing issues).

Anyhow, I think the issue you are having could be fixed by navigating in Orchestrator to Settings -> Deployment and choosing your Libraries to be Tenant instead of Host.
image

Could you give it a try? )

no luck. Option still disabled.
if you trying to add orchestrator link in custom url which throws below error.
“Response status code does not indicate success: 404”
@Cyril_Kuhns any updates when this feature will be available?

PS: working fine in stable CE v2019-10-0

DO you solved this ? i encounter this also

I have the exact problem. Is there a solution to this?

Hi @vincera

I managed to reproduce it. All it took to enable the option was to set my options in Orchestrator as follows:
image

And then Disconnect and Connect my Robot to Orchestrator :slight_smile:

Doesn’t work for me… I have the exact same settings and have reconnected the robot to the orchestrator.

This is what my publish dialog looks like when I choose to publish to orch.

But publishing normal projects works fine…

I believe the original issue was about the Orchestrator option being greyed out, which it isn’t for you on the screenshot above.

What happens when you try to publish?

It works now! :slight_smile: Not sure if I changed anything but it’s published without any errors!

1 Like

So, I’m not sure if you’re running into the same problem I had when I tried to publish to Orchestrator from Studio, but if you click the down arrow below the publish button in Studio you’ll find it greyed out if you don’t have any test cases, and it looks like publishing a UiPath project isn’t possible.

test-cases

But if you click on the heart of the publish button it will work, and you’ll have the ability to publish to the Orhcestrator tenant you have configured with UiPath Assistant.

This might not be exactly your problem, but hopefully it’ll help some new users wondering why the publish button is not enabled in UiPath Studio.