Publish Library to orchestrator

Hi All,
I just published successfully a project to orchetrator but I’m not able to run it on a machine that have only a robot because it is missing some of my custom library I published using a local feed.
Now I would like to publish them on orchestrator but I have the radio button disabled in publish window.
I checked some other topic here in the forum and found the suggestion to move to tenant the option under settings -> libraries -> feed but the orchestrator option is always disabled.
Could you please help me to understand what’s wrong?

Thank you!

1 Like

Hi @LeoB,
So you want to publish the custom library to orchestrator.
For this,
login to orchestrator,
go-to libraries
Upload your custom nupkg library

Thank you @shankm, I already tried to upload it in Libraries but it seems it is not used by my process.
I got back this exception when I try to launch it on a machine that have only the robot:

Cannot create unknown type ‘{clr-namespace:MyLibrary;assembly=MyLibrary}MyActivity’

Just to add some more details that can help, I created the library MyLibrary and then published using a custom feed locally on the machine. I added the dependency to my project and used the activity coming from the library and on my development pc everything is running correctly but when I published the project on the orchestrator and launching on an unattended robot I got back the exception I wrote before.

Thank you again for your help!

1 Like

@LeoB,
Can you find the custom package on
C:\Users<YOURUSER>\AppData\Local\UiPath\Activities ? On bot machine

@shankm
No there were no folder Activities under the path you suggested. Now I add it and I copied the libraries and everything works perfectly!
Thank you!
But why the orchestrator are not able to deploy the needed libraries? Do you think I did womthing wrong?

Thanks again!

1 Like

@LeoB,
Happy to know that worked :blush:
I also faced similar issue, that’s why I suggested the solution. That may be an issue with orchestrator or bot.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.