Level 3 -Assignment 2 - Cannot pass page 1 - No update in Queue

Hello,

I am trying to complete the Level 3 - Assignment 2 activity.
I have been searching for hours, but no solutions have helped me.
I am running my dispatcher, but it does not go past page one or record any data. All that happens is it opens ACME Work Items page, then closes 40 seconds later.
the reason is “Process finished due to no more transaction data” .
I cannot figure out why. I have tried multiple approaches from different forums but none have worked for me. I have tried adjusting my selectors, changing a few if statements and such.

Please help.
I have attached my ZIP
Generate_Yearly_Report_Dispatcher.zip (1006.8 KB)

In GetTransactionData.xaml , Click on Import argument and see if out_TransactionItem is assigned to TransactionItem.

If not, please assign it then this will be resolved.

Regards,
Karthik Byggari

@KarthikByggari
It is assigned already.

Any other tips?

Thanks for the speedy reply

Your dynamicSelector is not set incorrectly. When I tested the workflow, no data was found. Use the UI Explorer to find what the selector should be.

The main problem is the element does not have an LI attribute as in your selector. The other is that another attribute should be used to help identify the element. All in all, the best way to find out what the selector should contain is by using UI Explorer.

@Anthony_Humphries for my dynamic selector I used the ‘UI Explorer’ and copied that selector into my 'dynamicSelector variable.
Is there a better way to do this ?

That is one way to do it, but when I replaced the dynamic part with a number (e.g. 1), the selector was not valid.

Another way is to use “Indicate on Screen”, and it will load into the activity directly. To make it dynamic and also check if it is valid at the same time, right click where you want to insert a variable, and choose to insert the variable. Your selector will now be able to perform validation even if it is dynamic. This is not always the case, but will be for this example.

Thank you for the speedy replies.
I am currently working on updating my selectors now and will let you know what I get in return.

@Anthony_Humphries I used the UI Explorer again and replaced my dynamic selector with this, this text came straight from clicking the “2” on my work items page. " "

Still getting the same result.

Try the second option where you can insert a variable into a selector using the “Indicate on Screen” option and modifying the selector directly in the activity.

I have updated as you said still same result. Some progress in that now I get an output of “Processing transaction number: 0” But it ends right after that.
Here is my updated zip
I truly appreciate the help & patienceGenerate_Yearly_Report_Dispatcher (2).zip (1006.8 KB)

@Anthony_Humphries it seems now that the update in the queue is happening, the new issue is that it is not moving to the next page. I have even tried to simplify the process by moving from selecting numbers to just selecting the next arrow but this still isnt working

Make sure the transaction number is being updated by the time it reaches the time to go to the next page. Also, I’ve seen cases where using SimulateClick or SendWindowMessages does not work. You may need to set both of these to False if they’re not set this way already.

I have those boxes clicked. I am not sure what is wrong here but it is frustrating. I have spent over 8 hours trying to get one process to run.
Do you recommended starting over? or is there another form of help where someone could speak / show me my errors exactly?

After your GetTransactionData workflow, you set TransactionNumber to 0 if a TransactionItem is found. Otherwise, you add 1 to the TransactionNumber. I recommend doing the same thing to the transaction number as the base REFramework was doing instead.