Level-3 Advanced Training UiDemo GetCredentials Activity error

Hi,
I am facing an issue with the Get Credentials Activity of Level-3 Advanced Training in UiDemo for a long time.
Initially, the following error was popping up and then, I realized and added Get Secure Credentials activity by downloading the UiPath.Credentials.Activities Package.

But, after that, another error appears and the file is not opening now.

Please have a look. I have been stuck for long.
Thanks in advance.

Hi, can you please check that you are not accessing zipped documents without extracting them.
Also, please share your getappcredentials.xaml file

Hi. Thank you so much for your reply.
I have extracted the files and only then, I am able to access the workflow. So, there is no issue of accessing zipped files.
I am sharing GetAppCredentials.xaml file but it says that document is invalid when we add Get Secure credential activity.
GetAppCredentials.xaml (13.6 KB)

This seems to be fine, can you try to uncheck the “Private” checkbox in the properties panel and then try.

Also where exactly are you invoking this getappcredentials.xaml file.

The sequence we used is
INIT > INITALLAPPLICATIONS.xaml invoked > UIDEMOLOGIN.xaml invoked > GETAPPCREDENTIALS.xaml invoked

I have tried unchecking the “Private” checkbox. But, errors are there in the exception workflow. when I install the package of UiPath.Credentials.Activities, “document is invalid” message pops up.

The sequence of invoking workflows is correct but I am not sure of the arguments. I am attaching other workflows and config file. Please have a look.
~UiDemo_Login.xaml (9.5 KB)

GetAppCredentials.xaml (13.6 KB)

InitAllApplications.xaml (7.4 KB)

Config.xlsx (19.3 KB)

Have you tried installing all related packages (excel,credential etc?)

That’s what I was trying to say that when I install UiPath.Credentials.Activities Package, then the file becomes invalid.

Hi @harsh497, restart the machine and try it.

Installing the Credentials package should mean the GetAppCredentials.xaml file will resolve the errors you’re showing (I had these same errors a few days ago and fixed it that way). Are you sure you’re installing it and not uninstalling it?

Can you post a screenshot of your installed packages please?

@harsh497 These things happens due to workflow is created in one version of uipath and using that workflow in different version of uipath.

Hi. Actually, This was the screenshot after uninstalling the Credentials Package because when I Install Credentials Package, the file becomes invalid.
Here are the screenshots of the error screen and installed activities package screen.

So, what should I do now? Create the whole workflow again? Then, same problem will persist whenever an update arrives.

@harsh497 That kind of error happens sometimes due uipath error also. Close uipath studio and reopen the workflow, if workflow is created in same version, workflow open correctly without this kind of error. U can delete part of workflow where u getting error and then recreate it.

I don’t have idea what happens whenever an update arrives, You might need other help regarding it by that time search forum once u might get solution by urself also

Check below links it might be useful for you.

Thank you for sharing this. But, It didn’t help! I am not able to find UiPath.V7.activities package either in Manage packages.

@harsh497 I’ve got the same problems. Did you find the solution?

Yes, I did find the solution at that time. Try changing the versions of UiPath.Credential.Activities from Manage Packages. Let me know if there is any other error.

Regards,
Harshit Goyal

i have this mach problems Capture

Check versions of your dependencies and activities from Manage Packages and update them accordingly.

I was having this problem too. Downloading the credentials package worked.

Hello! I’m having the same problem too that’s why i landed here. Tried following your advice to check and install UiPath.Credentials.Activities in Manage Packages. And the screen shows what i’m seeing. It says Package not found in any feed, also when i put my pointer on the exclamation point it states “Package Installation Failure”. What would i do to get this installed? Need help. Thanks!