Level 3 - Advanced Training - Practice 2

studio
training

#1

I’m struggling with the transition from Main>Init to Main>Get Transaction Data.

I’ve extracted the data and have an assign activity to create the WIList variable, but I’m unsure of how this set of data rows is then used in the If activity of GetTransactionData.

The walk through shows this:

Where is “in_TransactionNumber” being pulled from? I suspect that “out_TransactionItem” is being created in the assign activity.

Also, what is the “in_WIList(in_Transaction…)” Value doing? Is it trying to reference a column from the “in_WIList” argument? Why wouldn’t it have quotations inside the parentheses?

Any help is greatly appreciated!

Brad


#2

“in_WIList(in_Transaction…)” gets the row which is specified by a row number (in_TransactionNumber-1).
The row number is zero based, so you have to decrease1 from in_TransactionNumber, which starts from1.

eg;
in_WIList(0)
in_WIList(1)

in_WIList(in_TransactionNumber-1)

You don’t have to surround the parameter with quotations because the data type of ‘in_TransactionNumber’ is Int32.


#3

Yukihito,

Thanks for the response. I’ve been able to sort out this issue now.

I’ve been able to successfully complete the workflow several times, but I am running into one final issue. When extracting the System1 DataTable I have to manually enter the total number of work items. I know “0” is what the walkthrough says as it indicates the maximum, but it doesn’t work for me. The activity gets to the final page of work items and sits until it times out with no datatable to show for it.

Let me know if you have any ideas to solve this problem.

Best,

Brad


#4

If the datatable doesn’t have items, make sure the Work Items just after extracted from System1 has ones in the condition of (Type = WI5 and Status = Completed).

Or confirm the datatable has items before assigning selected items into a variable.
dt_Wls.Select(“Type=‘WI5’ AND Status=‘Open’”).Length >0
If False, do nothing so that subsequent processes can hanlde it as NO items.

If I’m getting wrong about what you ask, let me know.


#5

Yukihito,

I don’t think I was very clear with my problem. I’m having issues extracting the datatable from the acme-test.com website. If there are six pages of work items with ten work items per page, I have to put “60” as the MaxNumberofResults for the Get Structured Data activity to get all of them. I should just have to put “0” to get all work items, no matter the pages or number of items, but it’s not working for me.

I hope that explained it better.

Best,

Brad


#6

It looks fine.

Reset your test data on the web page and…

  • what if set MaxNumberOfResults null (default;100)?
  • what if MaxNumberOfResults=0 ?

I’d like to know what the error is and where it occurs.


#7

This is what I get:

12/15/2017 12:47:52 System error at initialization: Object reference not set to an instance of an object. at Source: Anonymously Hosted DynamicMethods Assembly

It works fine when I manually enter the number, but this is the error when I have it set to “0”. Leaving the field null didn’t work, either.


#8

I remembered that I’d gotten an error while scraping data, and did set ContinueOnError True to deal with it.

The error in my case was;
System error at initialization: Cannot find the UI element corresponding to this selector: at Source: Extract Structured Data ‘TABLE’

I couldn’t find out the root cause…:sob:


#9

Yukihito,

Thanks for the suggestion. Still cannot get it to execute properly, though.

System1_ExtractDataTable.xaml (8.3 KB)

Any chance you can see any problems in the workflow?

Thanks for your help!

Brad


#10

Hi,

I have completed Practice 2 Assignment in Level 3 and submitted for evaluation but I am not getting “Next” button to move to next slide. I had submitted on 5th Jan.

Please suggest.

Thanks,
Saurabh


#11

Hello Guys,

I have submitted Level 3 assignment which is working perfectly as per the requirement, but still the evaluation gave me 0/100 marks.

Can anyone explain what are the exact expectations behind the assignment.

Thanks,
Madhura


#12

Hi, I get the exact same error and it’s driving me crazy. I’ve tried everything but it only works when the number of lines to scrape is set manually. Did you manage to figure it out?


#13

Did you complete the assignment? I am getting same error. Not sure what to fix ?


#14

Hi, I never found out why this error occurs. I ended up submitting the Assignment with a fixed amount of lines and since the data set stays the same for the evaluation, it worked.


#15

Thanks Alex for your reply. It started working after I recorded the work flow again. This time made sure that the maxnumberofresults was set to zero during the scrapping itself and was not updated later. Not sure why but it works now.


#16

I am facing the same error. i have set the transaction number to 1

Error getting transaction data for Transaction Number: 1. Object reference not set to an instance of an object. at Source: Anonymously Hosted DynamicMethods Assembly

In get transaction data, i am assigning value as TransactionList(TransactionNumber-1)
Please help


#17

Hey Brad,

Could you please help me on this issue? I followed your thread and able to complete partially on this workflow but ran into couple of errors. I am pasting my screenshot below.

Thank you for your help in advance.

Best,
Sid


#18

hi @siddu509

QueueItem shoule be datarow if i have good memory. Just check and correct type of variable and will be fine.

Regards
@fudi5


#19

Got my mistake!! Thank you for the advice :slight_smile:


#20

such a waste of time. I ran into the same issue and its still not fixed. I will need to do as other i.e. manual numbers