Assignment 1 WIList Problem


#1

Hey Guys,

I have one major doubt regarding WIList Datarow. In which WorkFlow we have to perform the following Steps that I have attached in the Screenshot


#2

Hi @Prabu_visu ,
It should be in Main.xml at Init state activity.
Regards
Balamurugan


#3

ok. I have also used that there only. After initializing whether I have to give this as input to GetTransactionData Activity .?


#4

Yes, the datatable should be passed for ‘In’ argument of a datatable from ‘GetTransactionData.xaml’ Invoke Workflow file activity.

Thanks,
Rammohan B.


#5

Hi Ram,

As u mentioned, I have passed as arguments to ‘GetTransaction.xaml’.Please have a look at the Screenshot and verify.

(Note: “in_WIList” is a DataRow[ ] argument that I have created in the GetTransactionData.xaml)

With Regards,
VP


#6

Yup. That’s right. My bad. Its not DataTable, its DataRow[].

Do you still see any issue?

Thanks,
Rammohan B.


#7

,Hi Ram,

Thanks for providing me support in completing the Assignment 1.Everything worked fine but only one transaction alone pending in the Work Items list and displays the following error.

With Regards,
VP


#8

Does Your TransactionNumber starts with 1.?

Whats the assign value of ‘out_TransactionItem’ under Then sequence of ‘GetTransactionData.xaml’? It should starts with 0. Like this, out_TransactionItem = in_FilteredWIs(in_TransactionNumber - 1).

Thanks,
Rammohan B.


#9

Thank you so much Ram,Finally it worked.
Without your support, I would not have completed Assignment 1.:slightly_smiling_face:


#10

Glad to know. Happy to help :slight_smile:

All the best for the next assignment.

Thanks,
Rammohan B.


#11

hi @Prabu_visu

Hi all
I am facing a similar issue and cannot find a solution . Please can you help .

InitAllApplication Workflow

the data rows are fetched as DataRow[] and the count is being displayed while in that workflow.
Please see snapshot below

image

Invoke workflow of InitAllApplications

But when I try to get the DataRow[[ out through the invoke workflow I can get the value out onto the main page .

Please see snapshot below.

Main WorkFlow

Please see some more info . in the main workflow the DataRow is not getting displayed.


#12

Do this in Init State, firstly Extract the data table as out Argument from ExtractWiItemsWorkflow like this -

just below that workflow assign Extracted items in a local variable WIList (variable in main workflow) like this -

image

After this go to Main - > GetTransactionData and create an In argument in_WiList and pas WIList local variable in it like this -

now when you access in_WIList argument in GetTransactionData.xaml you would have the required data rows.

Let me know if you get stuck in between


#13

Hi
sorrty for the delayed reponse, I was trying to follow the suggestions given , but still NO LUCK !!!
In the Init state , when I do an assign as soon as I get the datable out from the ExtractWiItemsworkflow, i get a faulted message in the ouput.
so I am assuming the value isn’t coming out of the invoke workflow on to init properly


#14

Hi @prankurjoshi, this has been fixed now. It was failing the second time because the Exception message was getting set and it was going to the Catch Logic.

This issue was that, Each time we execute we need to give new Login Credentials otherwise an excepion will be generatedd


#16

@balupad14 @prankurjoshi @Rammohan91 @Prabu_visu @manasa @dennis @Dominic @ClaytonM

Hi Guys,
I am invoking a workflow "System_Data_Extract.xaml through _Test.xaml. "
As soon as it exits System_Data_Extract.xaml it goes into an exception . I don’t know why .
Pease request anyone to help. I have been on this for a couple of hours without any luck :frowning:

I am getting the beow error image

_Test.xaml (9.2 KB)
System_Data_Extract.xaml (8.2 KB)

below is the page I am extracting the data from . if you stay on this page and run the workflow the ExtractDataTable will be created


#17

Hi, just making a quick reply…
There are 2 things:

  1. in your System_Data_Extract, you have variables and arguments with the same name. What you will usually want is only the arguments and delete the duplicate variables, cause there could be a conflict between variables and arguments.
  2. In your Catch of the Try catch, try putting either Rethrow or exception.Source which will tell you where the error is happening exactly, because it’s sometimes hard with just seeing the message.

Regards.


#18

okay,

Please find the update workflows .

System_Data_Extract.xaml (8.0 KB)
_Test.xaml (9.9 KB)

I put a rethrow and this is the message i got . I removed the duplicates as you mentioned

image


#19

Well that one is a different error than the previous one you posted. For that one, I would check your Attach Browser and make sure it’s correct and that the website is open with that selector.


#20

thats what i even thought while posting the screenshot after i removed the duplicate variables from the sysyem data extract workflow .
i guess on removing the extractdatatable variable from the variable menu the selector must have got removed .

my previous mail had the data extracted properly .
unfortunately i am not in front of my system now.
i will let you know in another hours time on how i go.

i thought i should mention while debugging i noticed that while just returning back to the main workflow(_test) from system extract workflow the extract table and the data row had null values .
i wonder what makes them null while returning
back to the main workflow??

when running the system workflow independently there are no issues .
its something that happens when passing the arguments from there to the main and the values become null and on return it goes to exception


#21

Hi Clayton …

you first point was what the issue was .:sweat_smile:

Thanks for that @ClaytonM . I really struggled on this one

Solution:

in your System_Data_Extract, you have variables and arguments with the same name. What you will usually want is only the arguments and delete the duplicate variables, cause there could be a conflict between variables and arguments.