GetTransactionData error (assignment1)

Hi, i have a problem in Get Transaction Data it say this :

This is my Get Transaction Data on Import Argument :

And this is my Import Argument from IntAllApplication :

I have put all the same name and type in each argument , but it still say no value for “in_WIList”…
What is the problem? Thank you

Please share your IntAllApplication workflow file where you are fetching WIList data row.

I believe you need to extract WIList from the extracted Work Items data table by filtering Type=‘WI5’ AND Status=‘Open’.

Hi, @Afiqah.Syuhada
please check the name in_WIList it is “IN” in the first image, but in the second image the name is different. please conform it. and try to make it “IN/OUT” if you are imputing that WIList and as well as getting it out.
If it is still not working please give us some more details,


@Afiqah.Syuhada you have to invoke System1_Login and extract Work Items (using Data Scrapping) Only one time at init stage.


So it should be done under first run Sequence in Init Sequence after KillAllApplications.

Get WorkItemList Out from Invoked System_1 ExtractWorkItem and Stored as your variable WIList.

Also mind that WIList is Data Row Array so index value will be starting from “0” and finishing “one less than WIList.count”

hi @divyojyoti.sinha , i have already extracted work items by filtering what you mention. This is my attachment :
InitAllApplications.xaml (7.5 KB)

hi @sathwikreddy i have already did the in/out , but it still not have a value , this is the screenshot :slight_smile:image

Hi Afiqah.Syuhada

Your initAllApplication should be be like this, as you have two application System1 and SHAOnline so here you are initializing both of them done.

Then in Your Main.xaml workflow after the IF first run, you have to invoke 3 workflows as per below.

In the Process.xaml workflow have to invoke 4 workflows as per the screenshot

In System1 Extract Work Item Data Table workflow after extracting the table assign WIList to ExtractDataTable.Select(“Type=‘WI5’ AND Status=‘Open’”)

And the way your direction in WIList were was fine the one in System1 Extract Work Item is Out and the one in GetTransactionData direction is ‘in’

Hope this will be helpful


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.