Keeps getting "Robot Unavailable" status after the 18.3 release

Hello There !

I’m currently training on UiPath and facing an issue since the 18.3 release occured.

I created an Orchestrator tenant, created a machine, a robot, environment, etc… And despite all this, When I enter the machine key, URL, I can connect to the Orchestrator plaftform, but I keep having the status “Robot unavailable”

I already tried to delete and re-create all the items on Orchestrator, and also a clean uninstallation / re-installation of UiPath components on my local machine.

I’m using the community edition.

Do somebody have any other track to follow ?

Many thanks in advance !

Hi @mmussler

Could you hover over the “Robot Unavailable” status and paste here the message that will display in a tooltip?

It states that “the machine key is linked to another machine” (I’m still using the same computer)

It seems that you are using a Machine key from a Machine in Orchestrator that is not setup with a Robot.

I created a second Machine in my working setup and gave my Robot the key from the Machine that did not have a Robot assigned to it. It results in the same error:

I hope it helps :slight_smile:

Unfortunately not.

As you can notice on the below screen capture, the robot is assigned to my machine, and has an environment as well, so I’m really puzzled about what I could do

Do you know if it’s possible to delete my Orchestrator tenant, and re-create another one ?

Could you also provide a screenshot of your Machines? Please make sure that the Machine key that you provided to the Robot is the same as the one of the Machine that is connected to the Robot in Orchestrator.

Sure !

Here are the screens from both Orchestrator, and Local Agent :



Hi @mmussler

You got “I” in the Machine screen but “1” in the robot name :slight_smile:
Took me a while to notice.

1 Like

awwww, you were right, and noticed it before me…

Basic keyboard/chair interface issue…

Sorry, and thanks a lot for looking at this :slight_smile: Now it’s OK