UiPath Connection issue (The machine key is linked to another machine)

Dear All,

I have an issue connecting Uipath studio with orchestrator. I followed all the steps provided by in many forums and finally successfully able to connect the UiPath Robot to the Orchestrator (By adding “account name and service name” at the end of Orchestrator URL. However, on the orchestrator site still display the status as disconnected. Meanwhile, on the UiPath robot displays a green checked mark “Unlicensed” and “The machine key is linked to another machine” when mouse is hovered.



Untitled4

If anyone knows how to fix this, please help me.

Thanks in advance.

Hh
Welcome to uipath community
Choose the robot type as development or unattended and try connecting again
To change the robot type we can edit that in the robot tab

Cheers @black14

I tried changing to unattended but still no sign of change. Do you have any other solution recommend?

Hi, I got same problem, how reset (removed service on orchestrator, created a new one, define new machine, but after connect on UiPath Robot, got unlicensed - the machine is linked to another machine).
How solve this ?

Please find the post that helped me resolve the issue in the below link

Three things to note before connecting to orchestrator:

  1. Machine name should be the same as the Machine name shown in the robot settings
    2.The orchestrator URL in the robot settings should be
    [https://platform.uipath.com/[AccountLogicalName]/[ServiceName]/]
    I found the accountlogicalname and service name mentioned in the orchestrator link as below: **https://platform.uipath.com/Nivetha/Nivetha/**user-activity?fid=126522&tid=125626&index=0&size=10&state=M4ewTgLgPgZglgUwDYBMrAgQwgqK5gIDGEcIAdlJsEQHr0AkADFAwIxQBMUAzFACwBdQUA%3D%3D
  2. Create a robot that is assigned to the Machine name as stated above and enter username(enter whoami in cmd for the right username) and enter the password used to login in to the machine.