Issue with Unattended bot, activities failing when logoff BOT vm and triggered from orchestrator

Hi All,

Can any one help me to solve below problem.

I have a problem with an unattended robot on an RDP, I succeed to launch the robot from orchestrator, I succeed to launch the robot with the rdp minimized. But, if I launch the robot with log-off few ui activities are failing.

my process is having many windows, like opening chrome and typing into field and extracting data from browser. all these activities are failing when i logoff bot machine and triggered from orchestrator.

Resolutions of Development system and BOT system is same.

Thanks in advance.

Have you tried checking the simulate type and click activities, that always works for me

Hello @Nagaraj_Palle ,

What are the messages when they are failing?

You can check the input methods, should be the ones that works in background I believe.

Play with Simulate property to see if works OK.


Are you using community, and is the robot service installed?

Hi All,

Click and Type into activates are working now after checking the simulate type and click. also performed below steps.

  1. I have included log message activities in work flow and isolated activities which are failing.

  2. Changed Image accuracy and the profile properties in the Click image activity and image exists activities.

  3. Changed Login To Console setting to “Yes” as shown in below.

but, still i have issue with Get Full Text activity.

I need to scrape data from application(Silverlight application). i have used Get Full Text activity but no luck.
Please note Silverlight extension already installed.

Can some one help me how to solve the data scraping issue.

Thanks in Advance.

Hello Ward,
We are using Enterprise 2019.10.5 version.

Thank You.


Thanks for your suggestion,
click and type into activates are working after checking the simulate type and click.

now unable to scrape data from application. can you help me how to solve this issue.
tried with using get full text activity and receiving selectors failed error.

Thank You

Hi Vasile,

I have problem with Output methods,
BOT is unable to scrape data using get full text activity.
do we have any other alternative solution to scrape data.

Thank You.