Unattended bot failed to find UI element


I am automating a website and everything works fine in attended, but when runs in unattended the bot is not able to detect a pop up and a click activity in that pop up is not happening. error is “Could not find the UI element for this action.” I have tried to use classic activities like attach window but still not working in unattended.
Please help

Thanks & Regards
Anit Michael

Hey @anit.michael

Does the issue occur in the same machine from where the attended is successful


Hello @anit.michael

Could you please check proper delay is provided before the clicking of popup.

Also is it happening only for one popup? If yes, could you please revalidate the popup selector eventhough its working in attedned.

Hey @Nithinkrishna
No it works fine. Error is when running it in a virtual machine

Are you logging into the VM then closing the RDP window without logging out of the session?

I have given delay. Yes so far only the pop up, the job will be faulted after that.

I will be kicked out from the VM when the process starts

Which means it’s in user mode !


The issue is solved, I changed the robo settings and it works fine now.

You shouldn’t be logged in at all. This is what’s causing your problem. Sign out of the session before starting the job.

Which setting did you change ?

I tried that too, Usually when i start the job i will be kicked out from the session automatically.

I set the Login to Console, allow development loggin, font smoothing and autodownload process to Yes, then it worked. The same is shown in the picture I shared

You don’t want it set to login to console. If you do that, you can only run one Job on that server.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.