Unattended robot - Getting disconnected while trying to perform UI action

Hello Everyone,

I’m trying to perform some UI activities on a web based application loaded using IE in my unattended robot and it always faults with error as follows:

"Remote Desktop Connection Disconnected"

Following are the sequence of steps performed before encountering this error:

  1. All RDP connections to non-production robot is disconnected.
  2. Job created from orchestrator.
  3. Orchestrator installs package in robot.
  4. Robot starts processing job.
    i. Execution begins.
    ii. Robot reads all configuration files and assets from orchestrator.
    iii. Robot opens IE and loads application using URL (I’ve noticed that the application is not loading fully).
    iv. Robot tries to click on an element and when it does, it encounters the above mentioned error and faults.

Things noticed:

i. The application loads correctly when run on local machine.
ii. On element appear - Does not work.
iii. Tried refreshing browser using - Hotkeys, clicking refresh button and refresh browser activity - But nothing worked.

I’m now stuck here and unable to proceed further because of this. Any help would be appreciated :slight_smile:

Thanks,
Santhosh

Hi @santhosh_krishna,
Please make sure your browser activities like click etc. have set simulate click or simulate type property.

Question:

What do you mean by this?

Leave it unattended mode when you stat job from orchestrator.
do not login bot machine.hope this help