Issue with type into password field

Hi all,

I had a workflow set up to open chrome and log in to a website. I’ve since tried to invoke this workflow elsewhere and have run into issues with the type into commands.

I’ve tweaked it a bit, so the invoked flow now requests a user and password with input dialog activities, and when it runs the username works fine. However, the password is not typed correctly (something considerably shorter is being input) and this then causes a log in failure and my larger programme isn’t getting off the ground.

Until recently the login workflow was working fine on it’s own. I think this is the first time I’ve tried to invoke it (and I’m fairly new to invoking workflows in general).

Has anyone had this issue before? What details do you need to drill down on the issue?

Thanks!

Hi,
Could you post your workflow?

Hello,

Had you checked on the in out arguments?

Also the password is in string or secure string variable??

a) There’s no in or out arguments because the workflow just handles a process. the username and password are entered as part of the workflow and are not inserted into from an external process.

b) it’s a generic variable. We do not use orchestrator and generic is how the input dialog activity outputs data.

is it possible for you to share your login workflow?
Also in the password type use a trim.
You can for debug purpose add a messagebox/write line to see what value you have in your password variable

For password you have to use ‘Type Secure Text’ activity and variable ‘Password’ has to be SecureString type.
image

in input dialog I have ispassword ticked, is this not enough? The workflow had worked fine with typeinto until being invoked.

I can’t change the variable type, as I get an error icon on the input dialog activity.

image

image

That’s how I had it configured already.

If password is set to variable type securestring then I get an error that it is incompatible -

should not be giving you that error.

did you try printing your value?

And, like I said, before it worked fine but now invoking it there’s a problem. At first the error was that the password was out of scale I think it was.

Invoking the workflow should not result in the password being entered in a wrong way.
However if you will debug your code/or add a writeline activity after the input box you will be able to see the password that is being captured in the variable that you are trying to type into. If the value is correct and still you see the value typed is incorrect then let us know.

In the write line you can do like this - “#”+Password.ToString+"#"
Lets see what happens :slight_smile:

1 Like

The write line has presented the correct password, but the password field is short and incorrect.

Could it be the special characters in the password? It would seem that it’s handled “.” and “&”, but is not entering the “<”. I think this is proved because adding the password from this point onwards and hitting login manually is successful.

I tried the type into with < & and . and its working
Do you have a ‘[’ and other char? Can you please list?

It may be something with the type into activities. It may be that the password field hasn’t fully loaded. Have you set a DelayBefore value and set WaitForReady to “Complete”?

I’ve had similar issues with other text fields in the past and that resolved it

You can also enable SimulateType property and try

AndyD: That can’t be the issue as it such a case I’d expect nothing to be typed in, or the last part of the password, not the first.

Nadim.Warsi: I’ve been using SimulateType, and as per the explanation before I am certain that it is the < where it is stopping. There is no [ in there. The other special character is _ and the other characters are standard letters/numbers.

In typeInto Type Password give some Delay in DelayBefore. give a try