Click activity is not working

studio

#1

Hi, When I try to click on an element the click activity is not recognizing the element.
This is the error that the robot is throwing,'Cannot find the UI element corresponding to this selector: ’

This is the selector,’


#2

@krishnakanth.k There is selector error use ui explorer and check


#3

I tried with Ui explorer also…It is giving the same error…

image

I want to click on the ‘Sign in’ link.


#4

@krishnakanth.k can you share link


#5

you mean the site link…?


#6

@krishnakanth.k Following selectors is working use this in click activity selector

/webctrl name=‘submitBtn’ tag=‘INPUT’ class=‘button blue no-ie-hack’ /


#7

‘webctrl name=‘submitBtn’ tag=‘INPUT’ class=‘button blue no-ie-hack’’
This selector is for ‘Login’ button…

But, I want to click on ‘Sign in’ link.


#8

Attached file is working you can check

Main (2).xaml (9.2 KB)


#9

Check this please
Main (2) (1).xaml (7.9 KB)


#10

Thanks guys…Its working…
i didn’t use the delay…That’s why it wasn’t working…


#11

With pleasure :slight_smile: