Issue in save document in IE in backend

uiautomation
orchestrator
robot

#1

Scenario:Download pdf file in IE, a pop up bar will come at bottom having options “open”,“save”,“cancel”.A down arrow will be present at right side of save button in that bottom bar.Click on that arrow and another pop up open.It have option “save as”. I have to click on that.That is working on VDI machine when i run it through studio and VDI session is connected.But when i schedule it on orchestrator and disconnect my session from VDI then it will download file ,click on down arrow that is right side of save button on bottom pop up.It will open another pop up having “save as option”.But robot is unable to click on that option.So how this will work even if i am not connected to VDI?

Steps to reproduce:Download any file through IE, click on save as option in pop up .But execute it through scheduling when you were disconnected to VDI machine.Means it will run in background

Current Behavior: Robot is able to click on down arrow but unable to click on save as option when i disconnected from VDI and scheduled from orchestrator.

Expected Behavior:It will Click on “save as” that is come when we click down arrow near to “save” button on bottom pop up bar option while vdi is disconnected and orchestrator execute it through scheduling.

Studio/Robot/Orchestrator Version:Studio:v2016.2.6165 orchestrator:v2016.1.6137

Last stable behavior:Studio:v2016.2.6165 orchestrator:v2016.1.6137
Last stable version:Studio:v2016.2.6165 orchestrator:v2016.1.6137
OS Version:windows7
Others if Relevant: (workflow, logs, .net version, service pack, etc): IE11,IE10


#2

Hi.
If it runs good while your screen is showing but only fails when you run it while not connected (ie from Orchestrator) then you might try running it using the “Invoke Workflow Interactive” using 32 depth and the same resolution you used when developing it. This usually resolves any steps that require cursor position or image recognition from my experience.

Regards.


#3

Already tried that it doesn’t workout for me.
I have tried this with send hot key activity , Click activity with simulate checked. Still not working.
Also Change the login to console to "false in UiPath.settings file still not working.
I tried another workaround , instead of click on down arrow right to “Save” and then click “save as” i tried to click “open” and when document is opened then click on “File” menu and then click “save as” .Here also robo failed to click on “save as”.