Not able to select 'SAVE AS" from IE frame

uiautomation
#1

How do I select “Save As” from Internet explorer frame.

I am able to click on SAVE BUT NOT ABLE TO click on the and select 'Save AS" .

I have tried to delay - Did not work

1 Like
#2

you should get a selector for the dropdown arrow.
click on that.
to get a selector for the “Save As” - open uiExplorer > select target element > press F2[this will give 3 seconds to select another element. During this time you can click the drop down and the sub menu will be visible] > click “Save As” option after the 3 second window is elapsed.

Now that you have selectors for dropdown and the “Save As” menu item you should be able to use the click activity as usual.

1 Like
How to use "Hardware Events" on a locked robot VM?
#3

Hi @sampaddas,

Try this code
Main.xaml (9.2 KB)

Regards,
Vikas

1 Like
#4

Use Hardware Events (no Simulate, Window Messages) and add a small Delay Before (1 sec)

5 Likes
Problem with Save As from web download
#5

It worked , Thanks !

#6

EDIT: I figured it out. You meant to uncheck both “SendWindowMessages” and “SimulateClick”. When I did that… then the “Save As” context menu finally appears.

Hi. Can you please be more clear about the solution for this? I’m having a problem with this as well.

I used the recorder to record the “Save As” process at the bottom of the IE browser, and the result was:

  1. Attach Window ‘The Browser Ieframe’ (the bottom save bar)
    a. Click ‘drop down button’ (the downward pointing triangle)
  2. Attach Window ‘Menu’ (the context menu that pops up) <---- Fails here. Menu doesn’t appear
    a. Click menu item ‘Save as’
  3. Attach Window ‘SaveAs Dialog’
    a. Here I click and type into ‘ToolbarWindow32’ to try to change directory
    b. Click ‘Button’ (Save)

Are you saying that on step 1a I should check the checkbox for “SendWindowMessages” and uncheck “SimulateClick”?

Are you also saying that a delay should be present just before step 1a?

I’ve done those 2 things and the “save as” context menu still won’t show up after clicking the arrow. I do see a faint dotted rectangle appear around the “Save” text in the button at the moment it tries to click on the dropdown button though, so I can see that something is happening. The “Save As” menu never shows up though.

#7

Hi @sampaddas I have similar issue , I tried from above ,Kindly help elaborating little more.

#8

The easiest way to overcome this is using “click image” .I used click image to make it consistent

3 Likes
#9

@sampaddas Thanks a lot for the idea …it worked for me too :slight_smile:

#10

Send windows message did not work for me. in this case.

#11

Hi @sampaddas

I was facing the same issue and this did the trick for me!

Thanks

#12

Hi, does any of the above solutions work in unattended mode? It was not working for me in unattended mode so I changed the logic as below:

  1. Click on Save button to save the file in default (Downloads) folder
  2. Move the file to desired folder with desired name
#13

In unattended mode we have used alt + “s” to save en default download. Then we use the “move” activity to move the downloaded file to the place we need and with the name we need.

closed #14