Having trouble with IE Save As dialog in unattended bot

I have a simple process where I log into a web site and click a few links to download files. The dialog pops up at the bottom of Internet Explorer where you click the down arrow then Save As.

When running via Studio on my laptop it works fine. But when run as unattended via Orchestrator - running in a RDP session on another server - it doesn’t work. It never clicks the down arrow.

I’ve tried various Selectors, and using or not using SimulateClick and SendWIndowMessages. Nothing works. I also tried the keyboard sequence of Alt+n, tab, down, a - which works on my laptop running attended but doesn’t work unattended whether with or without SendWindowMessages.

Has anyone successfully done this in an unattended bot?

Not sure this will help you, but do onething like, download the file and move the file using move file activity @postwick

That’s not a bad idea, I’ll try that.

Hi @postwick,

What happens to me is in Windows 10 I have to add a Retry Scope(never use delays) over the click down arrow because the element appears but it’s not being rendered.

On Windows server 2012 R2 it works with no issues.

I was finally able to get it to work. Here’s what I did.

I put a “Find Element” with a 10 minute delay (because this site is weird, sometimes it takes a LONG time before the download dialog pops up). The Find Element selector is:

"<wnd app='iexplore.exe' cls='IEFrame' title='Reports :: Create Exports - Internet Explorer' /><wnd aaname='Notification' cls='DirectUIHWND' /><ctrl automationid='IENotificationBar' /><ctrl name='Save' role='split button' />"

Then I did the four Send Hotkey activities for ALT+n, tab, down, a. For each of these I set a 1 second delay before AND after, and selected Activate and SendWindowMessages.

Hello @postwick,

can you please share a xaml of how to do that?

This worked for me - using on element appear with a click text …OnElementAppearsplitbuttonSave.xaml (10.5 KB)