Invalid machine Key on orchestrator


Hi @Soudios

Check this

Ashwin S

HI @Soudios

Have you given the proper machine name when creating the machine in the Orchestrator? This machine name should be similar to the machine name you see on the robot tray in the robot. Once created, copy that machine key and paste it in the machine key of the robot settings…

Try that again and see whether it works

yes i tried this solution

Can I see a screenshot of the robot and machine you created in the orchestrator and also a screenshot of the robot tray settings

1 Like

is the orchestrator URL as mentioned here

and if so kindly share the screen shot of robot tab with robot details from orchestrator

Cheers @Soudios


I see few things missing here…
You have not specified the environment on the robot settings… Create an environment and allocate the robot to that environment…

Also, just double check the username you gave when creating the robot… You have to give the domain\username. Which you get when you go to command prompt and type “whoami”.

Next thing, in the robot tray, the Orchestrator URL. it should contain the username and the tenant name along with the url link you provided…

These marked parts should be included in the link too…

1 Like

yah i got it
kindly mention the orchestrator url in robot tray as per this blog

and also ensure that the robot is tagged to a environment
for that in ROBOT tab click on ENVIRONMENT tab and create a environment and tag that

Cheers @Soudios


thank you !

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.