uiPath Robot Error - Orchestrator URL and Machine Key are required!

Hello, I am receiving the following error for the past two days, I see no much information in the forum about it. When I put the Orchestrator URL and Machine Key in the Orchestrator Settings in the Robot I keep receiving the error: UiPath Robot Error - Orchestrator URL and Machine Key are required!

  • The URL is the same as the Tenant URL: https://cloud.uipath.com/[AccountName]/[ServiceName]
  • I tried with the word platform instead of cloud and without the ServiceName, and without the AccountName, but nothing.
  • The machine key I get it from orchestrator just copying it, so is the correct one
  • The machine name is correct in both orchestrator and robot settings
  • I restarted my pc four times and also tried again shutting down the computer
  • Robot in services is running ok in my pc

One wired thing is that if I put the details like this:


Instead of an error of type “Machine Key Invalid,” the error is the same as I am putting nothing.

I don’t know what else to do.

Any ideas?
Thank you very much

1 Like

Hi @Luis_Martirena
Just follow the Video , I just created a video for U :slightly_smiling_face:

2 Likes

Thank you very much for your effort @Maneesha_de_silva, I did all those steps, several times, in different ways, and the error is still there.

1 Like

@Luis_Martirena
Yave you assign the same name of your PC for your machine name ? and robot name ?
check that

Hi @Luis_Martirena.

Have you tried re-installing UiPath ?

1 Like

If you are connecting to the Orchestrator Community Edition I would suggest start by upgrading your Studio Installation. The current Stable Version is 20.4.1

While you should still be able to connect with the version of Robot you have i believe there are some limitations with Modern vs Classic folders.

Hi @SamanGuruge, i was thinking of doing that, not Studio, only the Robot.

Thank you @codemonkee, I will try that.
Could it be that I have a licensed Studio and a Community Version of Orchestrator?

I have both Studio 19.10.4 [licensed locally] with UiRobot registered as a service as well as Studio CE 20.4.1 and ran UiRobot in user mode and have no issue connecting to Orchestrator CE with either of them.

I have not installed the MSI / Enterprise package for 20.4.1.

Thank you @Maneesha_de_silva, but both are correct. I also made several tries, just to be sure, and keep receving it.

Thank you also @codemonkee, I guess I will have to update the version of Studio I have (2019.10.4) and cross my fingers.

1 Like

So I uninstall version 2019.4 and install the new 20204.1 and now it is working. Thank you all for your suggestions.

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.