When connecting robot to orchestrator shows the message as Invalid machine key

After creating robot and obtaining machine key,when I connected the robot to orchestrator it shows message like ‘Invalid Machine Key’. I would appreciate any feedback on this issue.

Hi @Hridhya

Welcome to the community!

Can you share more details to easily address the issue like putting some screenshots of your error?

cheers :smiley:

Happy learning :smiley:

3 Likes

Hi @Hridhya,
Welcome to the Community!
Please check documentation:


And this post:

3 Likes

Hi
Welcome to uipath community
–make sure that you have used this url while connecting the orchestrator as per these steps

–and
Kindly check with these stuffs that would surely resolve your issue
— first create a machine in orchestrator and that machine name should be same as in your system
To get that name go to start-> search as robot-> settings and get the machine name from there and paste the same while creating machine in orchestrator and copy the machine key after this from orchestrator and paste it in your system robot tray and mention the orchestrator url as well
— the. Make sure that we have a robot created in the orchestra with the same machine name and while entering the detail for username and password go to cmd window and type as whoami which will give use domain and username, enter the same in the orchestrator while creating robot
— create a environment now In the robot tab and tag the robot created in the previous step to this environment
— now back to our system in robot tray we have machine key, and orchestrator url mentioned readily and now we can connect

Cheers @Hridhya

1 Like

Welcome to the uipath community.

Next time onwards don’t create topics under User Voice section. As of now I changed this.

If you want to suggest any new thing then create under User Voice section.

1 Like

Solved the error; the orchestrator url was wrong. Thank you for the support.

4 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.