Internet Explorer Problem

Someone already asked about this in a thread here but it is now closed so I can’t add that I am having this problem. Everytime I try to use Open Browser Activity with IE it crashes and says it cannot communicate with the browser. I’ve done the dll fix and doesn’t help. About the security options, I’m using with the Community Studio a laptop that was provided by my company, so the security settings are automatically managed and cannot be changed by me. So, I would like to know if there is anything else I can do?

Kind Regards

2 Likes

Is this random?
Does this occur with other websites or only a specific one?
If you load IE manually, is it slow to load?

The other day, I noticed this occurred with one of my associate’s jobs. I looked at the screenshot that was taken during the error, and the website was still loading. I tested IE manually and it loaded slowly once, but then it started working again after that.

If it’s a performance issue like that, then I’m not sure really, and the Open Browser activity does not have a TimeoutMS property. So I’m thinking a possible workaround for this would be to place the Open Browser inside a Retry Scope by itself to load the site first. Then, follow with Attach Browser or Window after.

I’m curious of solving this issue too, though.

1 Like

I can confirm it is not random, it happens everytime no matter what. Opening manually the browser doesn’t take more than 3 seconds, and that’s the worst case scenario I’ve gotten so far. I’ve done the online courses available, even Level 3, using Chrome and there were some issues with it that might have not happened if I was using IE, so I tried and I came across the error.

The solution you suggested doesn’t work since it is not loading related.

2 Likes

Check that you have the latest version of the UiAutomation activities. I think it’s 19.2.
UiAutomation is the same as Core Activities.

Also, make sure you are on IE 11.

Regards.

1 Like

The activities are up to date, 19.2. And I’m using IE 11.1563.150063.0, so yes, it’s the 11. It really makes no sense, the security measures from my company, and I assume any company, should only block unverified websites and obvious cases like that. Shouldn’t block a Robot from opening an App, but, when I check scripting options in Security tab of Internet Options, some of the options are set to ‘No’ but they are greyed out, can’t touch them.

Regards

Since you can’t edit security settings, are you able to add the site to a different zone, like Local Intranet or Trusted? The Medium-low or Medium might have the scripting security set right.

I don’t think that would make a difference since you can’t even load into IE, but maybe. There are a few security settings that need to be set to automate on certain websites for sure.

A workaround would be to use Start Process to load the website, then Attach to it. However, I wouldn’t count that as a permanent solution.
You can try tech support to see if they can help: https://www.uipath.com/company/contact-us/contact-technical-support

If it doesn’t help, then contact me through the slack community We have a new (Slack) space where we can get in touch!, and I can try and help further to try and figure out what is going on.

Regards.

2 Likes

Alright, your suggestion worked. I just had to add about:blank to trusted sites. Sounds silly, but yeah, now it works like a charm.

Thanks a lot! Best regards :wink:

Hi Jose,
If you find the solution, pls do update or create topic and tagged me , I have also faced this issue sometimes , anyhow I am handling it right now , but still curious for the solution .
Thanks,
Syed

1 Like

That’s good to know in case I run into same issue like that. Thanks.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.