Open Browser not working

core_activities

#1

I have tried all three browsers but Open browser is not working, it is keep saying Cannot connect to Browser.

Chrome&Firefox: I have added UIPath Extensions and restarted system multiple time still not working
IE: it was working a week before but now it is not working.

When i open IE with Open Service method, Robot takes approx 30-35 Sec for each action. Robot has gone damn slow.

Someone please help!!!


#2

Does this help!
Internet Explorer Automation Troubleshooting


#3

Try reinstalling the UiPath Browser extensions.
or
You can use start process activity to initiate a browser.
Provide the path of the browser exe.


#4

Tried both. registering regsvr32.exe & reinstalling Browser Extensions. Does not work.

“Start process activity to initiate a browser” makes Robot really dead slow it takes like 30-40 sec to for each action.

So any other option guys?


#5

Not sure this help but try it out.
Check Proxy setting.
So on IE try Tools>Internet Options>Connections>LAN Settings> then un check proxy server


#6

it is already unchecked. OpenGoogle.xaml (9.4 KB)

check this. this has only steps to open google and type test and click search. it takes more than a minute, which ideally should take hardly only few seconds.

and why does Open Browser stopped working?


#7

hope you don’t have slow internet connection. :stuck_out_tongue:
it’s taking more time to type"test" and click search button as “WaitForReady” property set to interactive.
Try to set to none and execution will be faster.

execution started
execution ended in: 00:00:04


#8

I have a Good Internet Connection. Well Thanks a lot “WaitForReady” to None works faster now.

Able to run my actual script in 10 seconds which initially took 10 Mins.

Just curious to know why Open browser is not working anymore which was working a week before.


#9

This is something not sure about.
May be issue with browser. Do you mind try reinstalling and see any changes (may be some updates happened in background).

Or try to update UiPath.Core.Activities package if available else just uninstall and restart the studio.