Open browser activity not working

I want to use Open browser to open I can see it’s opening the browser but can’t load any UI element. Because of that my program ended up timeout error.

Any suggestion?

Have you added the UiPath extension? Should look like this

Hi @ad2000

You can select ie from open browser property instead of Chrome and also is the page opened when you manually tried…


yes Uipath web extension is already installed.

Strange thing is when I manually run the program on Production, it works but when no one is monitoring, it results in timeout.

You mean change browser from Chrome to IE? but I selected all the elements using Chrome. Please note this program was working fine from past few months. It’s just recently open browser has stopped loading UI elements on the page.

Mabe reinstall the extension. That might help

I tried it but it didn’t work

I changed it to IE and can see UI elements are loading now. But then I have to change all the UI elements used before.

Is there a workaround using Chrome itself?

any suggestion pls?

did you allow - Allow access to file URLs and Site access

you mean in Chrome settings?

I am exactly getting this error -
RemoteException wrapping UiPath.Core.ElementOperationException: Timeout reached. —> RemoteException wrapping System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I tried to follow this Timeout reached - Troubleshoot steps
but I don’t use Orchestrator so resolution settings is not applicable in my case. UI elements are still not loading in Chrome but when user session is active, it works fine.

any suggestion would be much appreciated.