Installing UiPath - missing UiRobot service (18.1.3)


#1

Hi, I have spent the last couple of days trying to make community edition (18.1.3) work to no avail. The fundamentally issue is, after installing, I have no uirobot service visible in services.msc. I have tried to:

  1. Install on two different machines (windows 10) to check if there any peculiar config issues – same problem on both machines
  2. Use both ‘logged on user’ with local admin rights and evaluated rights to install – same result
  3. I can run UiRobot.exe (as logged on user or with elevated rights) which gives a tray icon but fails to connect to the non-existent service. This makes sense since no service has been installed

Any ideas? Thanks
Doug


#2

@Doug please open folder “Uipath studio” if uipath was updated from previous versions Under " Uipath Studio" folder u will see version installed on your system open the latest version folder, you will find robot file run it once afterwards you can find robot in “Icons tray”


#3

Thanks Manju,

I have found the file …\AppData\Local\UiPath\app-18.1.3\UiRobot.exe - is this what you mean by “robot file”. If I run this the tray icon will appear but after about 5-10 seconds goes red and reports that it can’t find the UiPath Service.

Thanks

Doug


#4

@Doug This is only robot file i dont why it is showing error. Better uninstall uipath and copy any files if u needed and remove uipath folder. And it may for work for you try it Once


#5

You have installed from the MSI which puts a UiRobotSvc in Services. That service is not started.
Alternative you can uninstall the MSI (and the service) and install only the community exe.


#6

Hi Mihal,

I have only installed the community edition. All the symptoms I have recounted thus far relate to community.

So, I am correct in understanding that, if I install the community edition, there is no service? If so, when I run the tray app and it says “Error connecting to the UiRobot Services” this is by design?

Thanks

Doug


#7

If you go to TaskManager->Services there’s no UiRobotSvc?


#8

Hi,
Unfortunately, I don’t see any sign of the service.


#9

Then I’m clueless. We’ll investigate. @Gabriel_Tatu


#10

Thanks -if you need any more info please feel free to ask. Doug


#11

Did you use the msi or the exe installer? Where is the installation path/folder?


#12

Hi, exe (UiPathStudioSetup.exe 2018.1.3) installed to C:\Users\xxx\AppData\Local\UiPath

Doug


#13

Then there is no robot service installed as a service, it runs in user mode-when you run a workflow only


#14

exe. there’s no UiRobotSvc.


#15

OK, so if this is the case, when a workflow is executed from Studio the process is created? If I try running from studio it fails with:

14:05:12:819 => [ERROR] [UiPath.Workflow.Logging.StudioTraceListener] [9] System.AggregateException: One or more errors occurred. —> System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/xxx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Thanks
Doug


#16

What process are you running? Try a simple message box first.


#17

This is what I’ve tried:
image