UiRobot Service is not visible in Services.msc


#1

Hi All,

I have UIPath 2017 Community edition, I have created a a process for moving files from one folder to another,the process is working perfectly when running through UI Path Studio,I have the published the same and created a nuget package as well.My issue is I need to run this process via UiRobot Service.
As per my understanding we have an orcestrator which manages the robot and the robot runs the process,as I have Community edition I am using https://demo.uipath.com URL.

I have couple of issues here

1)I cannot see the UIRobot Sevice,not in Service.msc or taskbar,how should i run the Process nuget package i created

2)I an using the demo Orcestrator,how can i add robots to the same,should i add the machine IPs?

Basically,I have my process ready,but i want to sort of host it.I am using the community edition.

Any help appreciated


#2

Hi,
1.Looks like your using windows 10. Please navigate to below directory and try to run UiRobot .Post to that UiRobot will appear in the system tray, from there you can connect your robot to Orchestrator.

C:\Program Files (x86)\UiPath Platform\UiRobot.exe

2.https://robot.uipath.com/docs/from-orchestrator-and-the-robot-settings-window


#3

Thanks for your reply,but I have already tried this option,in my case the UiRobot.exe is available at “C:\Users\UserName\AppData\Local\UiPath”.When I try to run the exe,I am getting the following error
"The Application has failed to start because its side -by-side configuration is incorrect.Please see the application event log"


#4

This is the error in the eventVwr “Activation context generation failed for “C:\Users\UserName\AppData\Local\UiPath\UiRobot.exe”. Dependent Assembly UiPath,type=“win32”,version=“1.0.0.0” could not be found. Please use sxstrace.exe for detailed diagnosis.”


#5

Hi @amitshah

Please take a look at this thread. Seems like you have UiRobot.exe in 2 places:


#6

@ovi lightning fast :wink: :zap: #flash


#7

Just wanted to share how I solved this problem. Basically I also couldn’t find the service UiRobotSvc on the list in services.msc
So I created the service in powershell (need to use it as administrator, right-click on the powershell icon and choose administrator) by entering: sc.exe create UiRobotSvc binPath = ""
Then open the services.msc and start the UiRobotSvc service.
In my case the uirobot.exe file was not under Program Files, eventually that caused me the extra trouble.
Hope this helps. Happy automation!


#8

Hi @GoncaloSantos ,
Can you please elaborate on steps you took?
I created a Powershell script with the instruction mentioned i.e.
sc.exe create UiRobotSvc binPath = “”

but it didn’t help.
Can you please guide more?

Thanks in advance !


How to delete an automation project published to a Robot not connected to Orchestrator
#9

Hi Tushti02, you need to enter the path where the uirobot.exe file is stored in your system inside the quotation marks. For me it looks something like this:

sc.exe create UiRobotSvc binPath = “C:\Users<my username>\AppData\Local\UiPath\app-18.1.2\UiRobot.exe”

Then simply run services.msc from the powershell and you will see that the UiRobotSvc is now included in the list.