Inconsistent behaviour, cursor position changing each time session! (fixed cursor position!)

So, two days ago I set all this worflow with UiPath. It worked good enough… it would usually break after some 10-12 loops (when I needed 1200 loops), but ok, it was good enough for a start, just needed to sort out some problems at the end of the flow.

Yesterday, however I opened our browser program that I need to automate and UiPath, and tried to run the bot.

NOTHING was working. In particular, when UiPath bot should click at OK at the botton right of some pages, the mouse would try to click it some 100-150 pixels ABOVE the real OK position.

And today… to my surprise, I tried running it again… and the mouse was trying to click OK some 150 pixels BELOW the OK position (ended up clicking task bar icons!)

Now, the funny thing is that for some reason, when I set this bot, I do not know what I did differently, but no mouse click is capturing containers or nothing. All click tasks have screenshots showing the entire screen, and have CURSOR POSITIONING, with TARGET fields empty.

Now, what is more weird, is that the POSITIONING in pixels is right!!

If I go to the “INDICATE ON SCREEN”, I check the pixel location of the click and it’s right. But when I run the bot, and it’s wrong.

I tried offsetting the cursos to a WRONG pixel position to click the correct location of the OK (like 1600x750, when the ok is actually at 1600x850) but then it broke OTHER tasks, even though I had not changed them…

Any idea what is happening? I t

can you share the selector for the OK button?

Actually, right now there is no selector, it’s empty. Which is good, because when I tried to use selectors, the mouse simply does not moves.

But let me catch the selector just for this post…

ok… right now I can´t get the selector. Just like two days ago, when I create an activity and go select the place in the screen, the WHOLE screen is shown as the container. (which explains why the screenshot shows the whole screen).

seems to be a Chrome plugin inconsistency problem, as it always selects the whole screen (and that is why it catches only the mouse position… although I am having problems with it too as I told). Opened Firefox and it’s catching the “containers/selectors” (it seems I am not sure about the difference haha)

here is the Selector, which I catched on Firefox


edit: how can I post the selector?? It seems the forum engine thinks the selector is a BB Code. Let me remove some marks, to see if it works.

webctrl id=‘mZ2Q9n’ tag=‘BUTTON’ /

edit2: yes, it worked above. If you quote me, I guess you can see the text between " marks… it had > symbols, which the forum misinterpreted as BBCodes.

If when UiPath gets only the mouse pointer location, it works faulty, capturing Selectors it doesn´t work at all.

I re-did my workflow at Firefox, where I was able to capture the selectors of the buttons.

When executing, the mouse pointed doesn´t even move…

i am sure you already tried this but what happens if you don’t work with a selector and just use the click text or click ocr text activity with text to be clicked as “OK”???

also what version of chrome are you using?

well, actually, this thread was created when I was NOT working with selectors.

Every click I was capturing on the Chrome screen was not giving me Selectors, but cursor coordinates only.

so is this resolved now?