Hi there! Is there a way to make UiPath read QAD ERP (Progress 4GL language). I’ve tried UI explorer, but it doesn’t see a window were QAD is opened. And “Click Image Trigger” doesn’t recognize it either and UiPath acts like it doesn’t exist. Is there a way to tell which exact pixel mouse should type in, so I could test if this resolve an issue?



Hi @Igor_Kulicenko

Welcome to our UiPath Forum! :slight_smile:

To answer your cursor position question, yes it is possible. All you have to do is specify the coordinates and it will click something even without the selector:

As to the QAD ERP, I am not familiar with the application, but if it is Java based then you will need to make sure you have properly installed the Java Extension from Studio settings (or with the Enterprise installer, if you own the Enterprise edition).
This should allow you to detect elements within the app.

Other things to try is to run Studio as an administrator in case your application runs with elevated permissions.

Hi Maciej,

sorry for late reply… easter :slight_smile:

this is exactly what I’m looking for. It may sound silly, but which activity is this? I looked over all click or type activities available, but none of them has this property.

many thanks.


pi 19. 4. 2019 o 14:49 Maciej via UiPath Community Forum napísal(a):

Hi @Igor_Kulicenko

It is the standard, most basic Click activity.

What is your Studio version and the UiAutomation activity pacakge (or Core package in case of pre-2018.3 Studio version)?

It feels like this property is available since forever though, so please provide a small update about your current version and let’s go further from there :slight_smile:

Hi Maciej,

I’m using the most recent trial version 2018.4.4. Testing functionalities of UiPath to see if it’s applicable for our company and QAD ERP (Progress 4GL language) is the last app that I’m struggling with since it doesn’t support elements or images. I found cursor position XY offset in options (can’t understand how could I overlooked it…), but it still doesn’t work. Mouse move to the position I set, but neither of single click/ double click, left button/ right button doesn’t work. Or better say it won’t do a thing. Is there some alternative solution for UiPath for apps where Elements/Images are not supported by UiPath?

btw. this is how it looks browsing thru UI Explorer. It all looks like a windows forms for UiPath, with no information or elements available in editor:

many thanks!


st 24. 4. 2019 o 10:14 Maciej via UiPath Community Forum napísal(a):

This is indeed quite annoying.

I found this reference which might be helpful:

Basically trying to run Studio (and Robot) with elevated permissions to see if more selectors will become visible.

I know for sure this method works for some apps (gpedit.msc comes to mind), so it might very well work here.

Also, as a last resort and because you are currently evaluating the software using actual Trial version, feel free to contact our Enterprise support channel here for direct assistance.
They are experienced in sorting issues of this kind, and would most likely be able to help directly with a screen-sharing session if you are up for it.

Thanks Maciej. Will check forum link or contact support channel if need. You very much of a help. Appreciate it!

have a great day!


st 24. 4. 2019 o 14:18 Maciej via UiPath Community Forum napísal(a):

1 Like

Maciej, just wanted to come back to you and say big thank you! I was able to work with QAD after making our IT to grant me local admin access and everything is smooth and slick with UiPath.

Appreciate your help and time!

all the best.


1 Like