Image activities not working when uipath robot trigger via Task scheduler

Hi Folks,

I have process scheduled via task scheduler, It is working fine when user session is connected. But when user session is disconnected from VM the image activity like “Image exist” and “click image” activities not working.

Thanks for help !!

1 Like

make sure the window is maximized buddy
Cheers @sandipauti

1 Like

Hi @sandipauti,
What type of robot are you using?

1 Like

@Palaniyappan - window is always maximized but we are triggering process from task scheduler. It is working fine when user session is connected but activity like click image and image exist not working when session is disconnected

@Pablito - we are using unattended robot and triggering process using Task scheduler

1 Like

Unattended robots can handle the image based activities only when have their own session and account. Can you describe how this scheduled task is starting/configured?

1 Like

@Pablito - We have central VM having multi user login functionality. We have configured task scheduler as follow:

  1. Created task and checked run when user is logged in setting of task scheduler.
1 Like

For Image-Based activities tasks and unattented robot the screen need to be unlocked for the robot session to perform them.

1 Like

@Pablito - You mean we need to login or unlock session when ever we want to perform some action right?

Is this possible from window task scheduler ?

1 Like

From my knowledge it’s not possible like that.

1 Like

@Pablito - Thank you very much for your replay, I have just one more question is it possible via orchestrator ?

1 Like

Yes it is :slight_smile:
https://orchestrator.uipath.com/docs/field-descriptions-robots

In settings tab there is a field called “Login To Console

“Enables the Robot to connect to the console session of the machine where it is installed. Additionally, it indicates if you can connect multiple Robots to Orchestrator using multiple users ( High-Density Robots ) or not. By default, the value is No . To enable High-Density Robots, set the value to No .
If set to No , the Unattended Robot creates an RDP session when executing a process.”

2 Likes

@Pablito hello i use CE ,when robot run login with orchestrator when locked screen,
my settings below robot is unattened,but it doesn’t work
screen still locked ,No automatic login

Look forward to your reply thank you

1 2

@yeelcl - Please make sure you for all image activity Image.Accuracy should be 0.6 instead of 0.8

Please let me know if it’s work