How to use get directory on FTP Server and pickup specific files?

Hi, I need to download files using ftp activities but I can only download all the files using download files activity which is time taking as there are around 2000 files. I want to download only specific files with a prefix “ABC…txt”.

is there anyway we can use get directory in ftp folder ? or any other way to pickup only specific files in version 2019 ?

Regards
Abhi

Hi @ABHI_S,
Have you tried already UiPath.FTP.Activities pack?

Hi there, I guess Uipath has very few activites related to FTP, I’m told to use Uipath original packages which is FTP activities. So within FTP session, I’m using download activity to download files, But I like to keep only specific ones on my local. I tried using enumerate objects, I can only read object info with file names but cannot download them while trying it with for each. Any help?

Right now I can see these

I’m not sure if you have the right package. Please be sure that you have this one:
image
This includes these activities:
image
Having this you should use enumerate files to search for files and keep them in output which is DataTable type. Then using for each activity go through each row and push string from current row’s first index to Download activity.

Can you please let me know the version you are using as I’m on 2019.10 and package version also ?

Sorry for my mistake. I was checking this to you when I realized I’m one version down from the newest one where number of activities has been changed. My mistake. Anyway same operation is doable using Enunumerate objects activity and then Download Files inside loop.

1 Like

Enum objects only giving me , object info or file name, how can I download :confused:

You need to build flow which will extract whole logic around how to get path to each particular file within FTP scope. It will look like this:
image

Here is the example project based on random web ftp server:
TestingProject.zip (165.7 KB)

1 Like