How to execute robot by command line?

Hello everyone,
The topics I found on this subject are a little old. In all of them, there is the option to run “UiRobot.exe”, but it seems that the name now is “UiPath.Agent.exe”.

When I’m executing the command line " C: \ Users \ fflei \ AppData \ Local \ UiPath \ UiPath.Agent.exe", the agent is executed normally, but when I try to pass the parameter that execute the specific robot I want, it does nothing.

This is the line where I run the robot:

"UiPath.Agent.exe -file C: \ Users \ fflei \ Documents \ UiPath \ robotRobot \ Main.xaml"

Can someone help me?

You should use UiRobot.exe for this. See the docs here for the CLI arguments https://docs.uipath.com/robot/docs/robot-command-line-interface

1 Like

Where can I found the UiRobot.exe?

C:\Program Files (x86)\UiPath\Studio by default

@req7 are you running Commmunity edition or enterprise?

My UiPath was installed in the path I said before:**C:\ Users \ fflei \ AppData \ Local \ UiPath **"

but I can’t find any UiRobot.exe in that directory

Community edition

With the community edition you have to keep in mind it will be updated automaticly. So make sure to select the correct version directory.

Please be very carefull with passwords if you use them. Use the windows credential manager for that. Don’t store your passwords in your uipath code.Even when you create nupkg packages, credentials can still be retreived.
Read this topic. The commands are still the same

At this time i have the 20.4.2 community version. So in order to start a simple job you can run this from a windows batch file for example. So it starts straight away and avoid the uipath assistant.

cd C:\Users\jvanmarion\AppData\Local\UiPath\app-20.4.2\
UiRobot.exe -file "C:\Users\jvanmarion\Documents\UiPath\testOpenBrowser\Main.xaml"
3 Likes

UiRobot.exe is in a folder within Local App Data. For example mine is at C:\Users{UserName}\AppData\Local\UiPath\app-20.4.1-beta0022\UiRobot.exe

You should use whatever the latest app folder is in your UiPath LocalAppData. As far as i know the documentation is accurate for this executable’s parameters.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.