How to execute a project in UI community Free version without login to UI path studio directly from cmd. I do not have UI robot

robot
studio

#1

Pls provide valuable ways to achieve this.


#2

If you have Uipath studio community version, you will have Uipath robot as well. Go to start, search Uipath robot. You will find it.


#3

You can run the bot from command line as well


#4

Thankyou for the response.

I had tried with UI robot . The status is offline. So each time it’s just opening the robot not executing the project


#5

open uirobot setting and insert orchestrator url and machine key and click on connect it

Use your laptop or desktop username and password fro creating robot


#6

Publish your code first.

image

And in Quick lauch, if you open UiPath Robot, you can find the published packages. You just need to click Run in UiPath Robot.

image


#7

Thanku for the reply. But I have tried this. My UI Robot is in offline state. I don’t know how to make it in connected state


#8

hope it is useful for you


#9

Have you gone through the steps or training on how to setup orchestrator and robot ?
Check this how to:


#10

You should start uiRobot service, in run type Services.msc and it will open all your service now right click on uiRobot and click on start (restart)


#11

I don’t even want to open the UI Robot . I want to create a batch file and in a single click want to run project


#12

Getting this error when I am trying to execute UI path project using cmd - Could not load file or assembly ‘CredentialManagement, Version=1.0.2.0, Culture=
neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find
the file specified.
ANy udea ti resolve this?


#13

Hi @shivanii

It looks like the machine that you are trying to run your project on does not have all required packages installed.