Running UIRobot from Cmd Line. Robot is not there

1st problem is that I do not see uirobot.exe per instructions here

I installed using this cmd line
UIPathStudioSetup.exe ADDLOCAL=DesktopFeature,Studio,Robot,RegisterUserModeService /Q

I do see UiPath.Agent.exe in C:\Users[username]\AppData\Local\UiPath

I have tried to run this from cmd line like this:

uipath.agent.exe execute -p [myPackage]

uipath.agent.exe execute --file c:\programdata\uipath\packages[myPackage].nupkg

In both cases the agent pops up but it does not execute. If I click the ‘>’ run icon, the process runs.

Is this agent same as the robot? What is going on here? Thx

1 Like

Hello @Constantine_Zachariadis, welcome to the UiPath forum community!

The agent is basically the new robot tray in the latest version. In order to run a process via command line you first have to navigate to the folder where the robot executor is.
Try the following steps:

  • Navigate to “C:\Users\ [username]\AppData\Local\UiPath” then there should be a folder there named “app-[robot version]” please navigate to that folder as well and the UiRobot.exe should be inside. The UiRobot.exe is basically the executor component of Robot.

  • You can try the following lines:

    • cd “C:\Users\ [username]\AppData\Local\UiPath\app-[robot ver.]” <- Navigates to where the UiRobot.exe is.
    • UiRobot.exe -file “C:[File Path]” <- executes file.
  • OR a more direct way:

    • “C:\Users\ [username]\AppData\Local\UiPath\app-[robot version]\UiRobot.exe” execute --file “C:[FilePath]”

Try giving it a go and tell me how it goes.

Happy automating! :vulcan_salute:

1 Like

This worked perfectly, thank you very much.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.