To start a Uipath job on Cmd line

Hi Team,

We have Uipath enterprise edition, So whenever we try to execute a job on command line as: “UiPath.Assistant execute -p C:\Main.xaml” or with the package name, it just leaves the uipath assistant window openand nothing happens. So my question is am i doing anything wrong or the cmd line uipath job execution is only for Community edition using Uirobot.exe ?


Regardless of edition, we can run process or xaml file using UiRobot.exe . Please see the following document.


Hi @KiranP, hope you’re doing well!

You need to use -f if you’re specifying a file, please see Arguments Description for more.

If you want to see the logs of the execution of the process, the default location is %localappdata%\UiPath\Logs<shortdate>_Execution The format for <shortdate> is yyyy-mm-dd .

You can find more on logs here.

Let me know if you have any questions!



1 Like

Thanks Lisa, tried to follow the instructions in the Arguments Description ( link but they all just opens the Uipath assistant and still no process running after

Is the type of robot matters? I am running with studio license.


Also i don’t find Uipath robot.exe, instead “UiPath.Assistant.exe execute -p Test”. as we have the enterprise edition.


Can you try to run UiRobot.exe at C:\Program Files (x86)\UiPath\Studio?
(If you use the latest version, it might be at C:\Program Files\UiPath\Studio.)



This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.