How to configure proxy on Config files/Webhook.config

Hi Team,

Just wanted to ask what’s the best way to configure proxy settings on orchestrator config files. I’ll try to explain what im trying to do as best i can

Due to our environment setup i would need to use proxy to be able to hit a URL. What i’m basically trying to achieve is send a webhook notification via our Orchestrator to Microsoft teams. The problem im having is when i start any activities in our Orchestrator, it doesn’t hit the powerautomate endpoint and after a bit of digging around and troubleshooting we found out this is due to our Orchestrator server setup the way it is and the only way to bypass is to use proxy.

I’ve already created a powerautomate code to parse the information into a microsoft teams acceptable format - i just need the webhook to hit that URL so it can post into Teams.

Any help would be great!



Hello @bpgacad!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi Brian (@bpgacad) ,

I am facing the same issue. I tried multiple things but never got WebHooks to go through a proxy. Could you find a solution yet?

I installed on port 8080 to reqeuests going through the proxy right away.

First I only set the windows default system proxy settings with no effect

Next I set values in Orchestrator and WebHooks web.config
"C:\Program Files (x86)\UiPath\Orchestrator\web.config"

"C:\Program Files (x86)\UiPath\Orchestrator\Webhooks\web.config"

Still no effect.
Then I tried applying the settings as described here



and winhttp

But still no effect.
Does anybody else have an idea where to configure webhooks to go through a proxy?

@cornelius.nowald @bpgacad were you able to resolve this issue with webhooks and internet proxy server?