How to assign developer permission for Studio Web


I am trying to give myself developer permission for studioWeb on my Community Account, but I get the error in the screenshot.

Any ideas what could be the problem?

PS. I have been using Studio on-prem for a while, is that license conflicting with my studioweb license?



Can you check if your Assistant is connected to Orchestrator?



From your license page can you check if you have community and automation developer named user is assigned ?

Ideally studio web needs a names user license

And in orchestrator → tenant → manage access …check if the user youa re logged in has a automation dveeloper license give to him


Hi @Martijn_Wijffelaars

If you have an existing Studio on-prem license, it’s possible that it is conflicting with your attempt to grant yourself developer permissions for StudioWeb on your Community Account. Some software licenses may not allow multiple instances of the software to run concurrently or may have restrictions on using different versions of the software at the same time.

It’s also possible that you do not have the necessary permissions or access rights to grant yourself developer permissions for StudioWeb on your Community Account.

I believe my Assistant is properly connected to Orchestrator:

@Anil_G I am not sure if my user has the appropriate permissions for this. Can you see from the screenshots whether I set the permissions correctly?


In your admin please give automation user as well…Also I dont see that permission set in the manage access page aswell…please give automation developer and user license also in manage access

please validate

Allow to be automation user and automation developer is to be given


1 Like

Hello @Martijn_Wijffelaars. The error you have encountered is due to our policy that prohibits users from assigning roles to themselves. As a member of the Administrators group, you already possess the Studio Web Administrator role. We acknowledge that the message you received may be unclear, and as such, we will work towards implementing an improvement to better address this scenario.


@danieldinca helped me offline and found the issue. I still had the old User License Management setting turned off, which was used in licenses older than about 2 years.

User License Management can be turned on like this:

  1. Go to Portal, Admin, Settings, Advanced and enable User License Management
  2. Go to Settings, Licenses and check that you have a license allocated to a group that you are part of or that you have a license allocated directly to the user (see example in image)
  3. Sign in to StudioDesktop and StudioWeb to check whether it works.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.