High-Density Robots not running simultaneously

Hello all,

I have a Windows Server 2016 with Remote Desktop Session Host enabled, to execute robots in High-Density. In Orchestrator there are 2 robots provisioned, each with a different Active Directory user credential, and using the same Machine key. For these two robots I have scheduled a process to run at the exact same time.

Orchestrator, however, is executing the processes sequentially, not simultaneously. The second process only starts when the first one is completed. It awaits for the first process in Pending state.
I need them to execute in parallel, simultaneously.

Some extra info about the setup:

  • Robots were created using the “Create another” check-box.
  • Robots were created using the NonProduction type.
  • The robots are running in the same Machine (WinSrv 2016).
  • The server allows for two RDS connections at the same time.
  • The same behavior occurs using one process or two different processes.
  • Orchestrator is installed in another server.
  • In Web.Config file, I noticed there is no parameter for <add key="Robots.HighDensity.Enabled" value="true" /> … should I add it? (and restart the server?)

What am I missing? Why Orchestrator is not executing the robots simultaneously?

Thanks in advance for any help

Hi @Thiago

Other important setup is LoginToConsole property set to “No” or “False”. Both robots must be set that way.

image

And you must have 2 licenses and then set up 2 runtimes to your executor machine.

image

Add to this the solution I think by going to licenses page and click “SEE MORE” to edit runtimes per machine as indicated in @Juan_Felipe_Carvajal Reply. I’ve test and work simultaneously for all robots in High Density Machine. ^^
I found the solution from here High-Density Robots: implication on license