High-Density Robots

studio

#1

Hello,

I’m trying to configure high desity robots to allow multiple users to work on the same machine. I did the following:

1)Changed the config file pointing the WorkDir and LicDir to

<WorkDir>%localappdata%\UiPath\License</WorkDir>
<LicDir>%localappdata%\UiPath\License</LicDir>
  1. Set the LoginToConsole parameter to false , in the UiPath.settings file from the
    %ProgramData%\UiPath folder, for each Robot . (By default, this parameter is set to true .)

  2. Restarted the service

Still when multiple robots are running concurrently, only one runs and others get “No Robot Available” message. Do I have to reregister the Robot(s) to the orchestrator?

UPDATE: I tried to reregister the Robot but it did not work. After that I don’t see the Robot Name in “Per Robot” credential assignment. I have add the Robot and Credentials Back.

Please suggest. Thanks.


#2

Hello,

How did you provision the robots in Orchestrator? For High Density you need to check the Create Another option at the bottom of the screen.


#3

Thanks. I will try and let you know.


#4

Thanks @Cosmin_Ion_Nicolae it worked!


#5

Is it just to make sure that the key is the same or does it do something else under the hood?
Create another option is only available when making new robots, so there is no way (that I know of) to add new robots later to an HDR server if it’s not just syncing the Key.


#6

Hey @andrzej.kniola

Just in time :wink: …Any idea what could be reason for below error.I get this error when I try to run the job from Orchestrator.

Initially Orchestrator Event Viewer logged “Execute Permission Failed to a stored procedure”, later I gave Execute rights to the Sql User. Now I don’t see anything in Event Viewer but still get the error


#7

It would be guesswork from my side, I don’t have much hands on experience in HD robots. Hope someone else can help.


#8

I made few changes that I mentioned in my 1st post besides specifying same machine name and key.


#9

Can you please confirm no other changes are required other than using same Machine Name and Key but different Windows Credentials? Just want to make sure there won’t be any issues moving forward.

We were told to modify the License Config file to point to below localappdata instead of ProgramData, but that did not work.I have to change it back to ProgramData to make the multiple Studio and Jobs work on same machine but difference user instance.

<WorkDir>%localappdata%\UiPath\License</WorkDir>
<LicDir>%localappdata%\UiPath\License</LicDir>

instead of (THIS WORKS)

<WorkDir>%ProgramData%\UiPath\License</WorkDir>
<LicDir>%ProgramData%\UiPath\License</LicDir>

#10

Hi, i’ve the same Issue.

Did you have solve this problem?

Thanks in advance.