Getting error as "Cannot act as user <domain>\<username>. Make sure UiRobot is running as a service!"

Hi Guys,
Kindly help me here… I have been struggling to run my robots previously created and also created few new one using Latest Community Edition studio. Whenever I run process in studio, I keep on getting below error since two days even after I tried every option listed on forum but still missing something and hence finally decided to put it on forum to get advice from you all.

I could connect my robot on Orchestrator using the user id as “<username>” as I am on domain. I can see my robot active on orchestrator as below.

error I am getting is,


Kindly help me understand where I am getting wrong.

@Ratan_Gawai usually you get this error if the Robot credentials you’ve set in Orchestrator are wrong. Please double check them.

For the exact Username you can open a Command prompt and type: whoami . For the password, make sure you type it correctly.


Thanks ksrinu070184 for quick response. I appreciate it.

What exactly should I look into in for credentials in Orchestrator? I entered everything correctly as per my knowledge and hence I can see robot is connected and in “Green” status.

Please advice.

When I enter whoami in cmd, i get below,


I entered the credential in Orchestrator as below,


Anything else i am missing?


Can you refresh your robot service once, also check any other robots are deployed previously, because community edition has limitation of 2 robots. check it once.


Hi Srinivas,

I never deployed robots using CE before. I had old version of CE installed 4-5 months ago and then I installed trial version where I used Orchestrator’s demo platform and deployed limited robots. Once trial is over, I uninstalled it and then installed CE latest version 18.3.0 where I am trying to deploy one robot using CE orchestrator.

For refreshing the service, is this what I should look for in task Manager?


because I can not see any UiRobot Service anywhere either in Task Manager or in services.msc.

Kindly Advise.

Click windows and search UiPath Robot :slightly_smiling_face:

Hi Vivek, Unfortunately nothing in found in Windows for UiPath robot.
Kindly advise.

Hi @Ratan_Gawai

Could you click the small arrow on the left to expand the field? I am quite sure there is a Robot hiding in there :slight_smile:

Hi @loginerror,
Yes its there,


I ended the task for this service and it restarted again. I closed UiPath studio and restarted again,

I am still getting same error as below


Could you provide a view from the Task Manger similar to the below screenshot?


@loginerror, please see attached below,

These are the available user I have,

Issues with different users. How do I make my service run for user rg36218 ? Please advise.

Finally, I could sort this out with the help of hint given by @loginerror, thanks a lot.

It was issue of users, All (Studio, service and agent has to be logged in with one user)
and Orchestrator has to have a same user as you are using for above three.


Appreciate all users who has made it possible and supported me in resolving this issue. Thanks all !!