Cannot act as user UIROBOT. Make sure UiRobot is running as a service!


#1

How do I rectify this error. I have started UiRobot.exe and I have also tried going to component services to start the service but the service is not available in the list. Any help in this regard is appreciated


#2

If you have installed the CE & .exe installer, the Robot will not be listed in Services but it is running under the User session(in user-mode).

Usually you get this error if the Robot credentials you’ve set in Orchestrator are wrong. Please double check them. For the exact Username you can open a Command prompt and type: whoami . For the password, make sure you type it correctly.


#3

check this:

Regards…!!
AKsh


#6

Hello @jamnanin?
maybe try to run it as administrator (command prompt)?

Or try “whoami” in Package Manager f.e.

br Jakub


#7

thanks. but it works now. just change the directory to system32 and then run the command


#8

Thanks…


#9

Hi, I see your error was rectified. I have installed Community Edition on my laptop (under Admin) and I successfully created a Robot with ‘Admin’ user. My laptop also has a user account ‘User222’ . I created another robot for this account successfully but when I run a process with this robot, I am getting this exact same error.

I think My Uipath Studio is installed by default on Admin User, so is it mandatory that I login to User222 before running process from second robot? Or is there a way to run processes from Robots using other guest accounts on your PC?