GetAppCredentials not working properly

Hello Team,

This is just to let you know that while using GetAppCredentials framework, I encountered a number of errors (missing or invalid activity) regarding the GetAppCredentials. While creating a REFramework, I realised that the GetAppCredentials framework was missing. So I downloaded from GitHub site and pasted it in Frameworks folder. Hence, ‘missing or invalid activity’ occurred. Please have a look at the below screenshot for your reference.

Secondly, I am getting an error while using the ‘invoke Method’ activity whenever I am using any kind of methods such as ‘Add’, ‘CharAppend’, etc. Kindly have a look at the same screenshot for this as well and let me know your thoughts for both the topics.

Thanks and Regards,
Abhishek Shetty

1 Like

@shettyabhishek120693, I assume you used the framework from the UiPath Studio right?

You did not necessarily have to go on GitHub to download the missing package, everything is available inside of studio. Below are the solutions:

  1. You could just close the project, delete the Project.json file, and the open the project again, the project will load and rebuild the Project.json file, and it will install all required packages and imports needed for it to run, including the “GetAppCredentials”.

  2. You could open your project, click on Manage Packages → Select Official → in the search type in, UiPath.Credentials.Activities or whatever name of the package you want to install and then proceed to click install.

Now the errors you are getting, i am not sure but it could be that the type property of the invoke is not set to accept string/char but you can send the exact error message you are getting and or take screenshots.

Hi @Senzokuhle Dlomo,

When I noticed that the GetAppCredentials file was missing, I pasted the downloaded file in the framework folder and used it. After which I encountered the errors in it.

Thanks for the solutions mentioned earlier. I have tried to acquire the GetAppCredentials file by deleting the project.json file and by installing the UiPath.Credentials.Activities package. However, I am still unable to find the GetAppCredentials file Please refer the attached screenshot (named as GetAppCredentialsNotFound.png) for your reference:

Kindly revert back with the solution regarding the same as soon as possible because I am stuck with it and wasted my lots of time investigating it. So, it would be great if you assist me on this one.

Thanks and Regards,
Abhishek Shetty

@shettyabhishek120693, I do not understand, what are you showing me in the screenshot?

I do not see any error message on the image.

When you create a REF project from the studio, the files that are there, are there and the ones that are not there, are not there, why you assume files that arent there SHOULD have been there? If you choose to include an old file there, then some consequences might appear…

Hi @Bruno Correa,

The thing I am saying and concern about is that the GetAppCredentials file is missing while I create a new REFramework. Because of which, I am unable to use the same in my few projects for the credentials. So, could you please help me out with this?

The error mentioned in the earlier mail is regarding the “missing or invalid activity” occurred in the pasted GetAppCredentials file (pasted from GitHub site). So, is there any way to tackle this?

Also, is there any additional package I need to install? I have already installed “UiPath.Credential.Activities” package in my Studio.

Does my concern make sense?

It would be great if you help me through this as soon as possible.

Thanks and Regards,
Abhishek Shetty

It is not missing as an error, it just do not exist anymore… that was what i was trying to say…

So which file we can use against this any idea ?

GetTransactionData ?

I am also facing same error can you please help me in this

Hi @Komal_Surjuse
check whether this package is installed Uipath.Credentials.Activities

If so plz downgrade to lower version and try

Yes the package is installed bt stil not working…how to downgrade to lower version plz help I am new to this technology.

hi @Komal_Surjuse
go to manage packages and click on all packages , search for desired package and click on version and select lower version and try it out

It means I need to change the version of
Uipath credentials activities right?

Yes @Komal_Surjuse

Hey thanks it worked well…
Can u please let me know in which activity package I will find open browser activity in uipath 21 version

You can find the Open Browser activity in Uipath.UIAutomation.Activities

Can you confirm that Modern Design Experience → Disable


Hi @Komal_Surjuse

Have a look on this thread for GetApp Credential



Regarding GetAppCredential
Please close that topic and mark as solution , which will be useful for new members

1 Like

For this please raise a new topic so it doesn’t come under this category,

for Open browser - UIpath.UiAutomation.activities Package ( needs to be present )