GetAppCredential missing or invalid activity

Hello, i searched this problem in forum but my problem was not solved. My studio is 2021.4.4

First i created new reframework project but getappcredentials.xaml was missing so i downloaded it from github. Then i downloaded credentials package but i met 3 errors and there was a missing activity in sequence

Could not find type ‘GetSecureCredential’ in namespace ‘http://schemas.uipath.com/workflow/activities’. Row: 92, Column: 18
Could not find type ‘AddCredential’ in namespace ‘http://schemas.uipath.com/workflow/activities’. Row: 102, Column: 28
Could not find type ‘RequestCredential’ in namespace ‘http://schemas.uipath.com/workflow/activities’. Row: 96, Column: 24

I tryed to download whole reframework folder, downloaded package and same errors
Also in activities there is addcredential,getsecurecredential and request credentials.
How can be those are missing ?
I began to think studio is making fun of me

@Oguzhan_Celik
Ensure following package is added:
grafik

In case of the problem still remains, then we do have a package version missmatch. In such case the referenced package vesrions (at least UiPath.System.Activities, UiPath.UiAutomation.Activities) are different between REF Project and current UiPath Project. Just compare the two project.jsons and adopt it

1 Like

All my packages are updated. getcredentials.xaml’s last update is 2019. My studio is 2021.4.4
If this is the main problem, there is no way to find and download it. I must do my own getcredentails.xaml .

I got back to old version of UiPath.Credentials.Activities and my problem is solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.