Getappcredentials is missing in framework

Hi getappcredentials.xaml is not found in framework how to get that ?

3 Likes

Hi @Keerthana_Priyadhars,

See if this helps: basically, try to update or install the credentials package from manage package.

https://forum.uipath.com/t/uipath-credentials-activities-package-not-found/141868/18

2 Likes

Hi @Keerthana_Priyadhars,
Install the package manager.

4 Likes

Hi @Keerthana_Priyadhars,

I believe your problem is missing the xaml file itself. You can always create a new REFramework project and the GetAppCredentials.xaml is a part of the framework, hence you will find it under the “Framework” folder.

Regards,
PD

1 Like

@Keerthana_Priyadhars I’ve noticed this issue as well with the GetAppCredentials.xaml in newly created ReFrameworks for v.19.10.x (specifically v19.10.4).

I don’t know if this is a bug, what you can do is to simply copy the GetAppCredentials from previous ReFrameworks.

Here’s a github link: https://github.com/UiPath/ReFrameWork/tree/master/Framework

After downloading and copying .xaml file into the Framework folder of you ReFramework you must then download the package: UiPath.Credentials.Activities via Manage Packages so that the issue with dependencies will be fixed.

Have a great day! :vulcan_salute:

4 Likes

thanks for the reply. I installed it… still i cant find them !

Can you tell me what version of UI Path studio you are using?

Good day,

I am having the same issue. This is happening to me within Studio v 2019 10.4.
I tried starting a new REFramework project and the GetAppCredentials activity was still missing.
To get the GetAppCredentials.xaml file, I looked on the UiPath Github repo, and created the XAML file within the Framework folder.
Then, it appeared in the Activities pane, but was not recognized by Studio.
Next, I proceed to download the package in the UiPath Gallery page, but was unable to find it there.
Please provide guidance.
Thank you in advance.

I am having the same issue.
I copied from older version of Studio and the Get Credential activity is not recognized.
Instead of fixing this, where I can get the GetAppCredentials.xaml ?
After generating the REFramework from latest version of Studio, this sequence is not added.

This is the fix!
I think devs needs to include it for the generation of the RE Framework. What if someone is taking the exam part 2.

1 Like

After copying old GetAppCredentials.xaml, you should download package called “Credentials” from Manage Packages. Then it should work.

1 Like

i have everything in the manager but still cant find it…

You need to take it from git. I have made this guide for further reference

3 Likes

pls seee the other screen shot …
i have it but not appearing in frame work

thankyou

was the problem solved?please post the solution here

follow @AndersJensen sollution . video…i have resolved the problem after watching it

System1_Login: Cannot create unknown type ‘{http://schemas.uipath.com/workflow/activities}GetSecureCredential’.

after following the above video this is what i got …

Good day guys…
i have tired all (above solutions) but still c’t find a fix.

You can get it from GitHub, link below:

Now GetAppCredentials is not included by-default in Framework probably due to below note/reason:
Note: In Production, you might want to avoid using the GetAppCredentials.xaml file, for a more controlled behavior. You typically know the exact location of a set of credentials, which enables you to retrieve them easily. If the credentials are stored in Orchestrator as Assets, simply use the Get Credential activity in the Orchestrator category, under Assets. .

So alternatively, you can use ‘Get Orchestrator Credential’ activity and fetch credentials.

1 Like