Get outlook messages activity failing

I’ve been using the activity in a robot since 2 years and other bots also in my job.
Get outlook mail activity with 300,000 timeoutMS and retreiving top 800 emails which is rarely the case because bot is always processing them, however since yesterday morning the bot is always running out of time.
i reduced to 200 emails and 400,000 time out and still fail.

I don’t know what happened and if it’s related to server or UiPath it self. i contacted our IT and nothing have changed so i’m wondering if somebody from UiPath have explaination.

Hi can you try updating your UiPath packages?

i tried that… i’m using 1.9.5 mail activities because of the send smtp activity which doesn’t work since 1.9.6 but yes i tried to update to 1.10.5 and still same issue

You may try to update the Studio/Robot to 2022.4.4 and retry the process.

cannot do that. it’s enterprise studios and i’m not permittied to update. and it’s many users and many bots.

we haven’t changed anything from ourside though. and issue started yesterday morning
since then me and my colleagues have multiple bots failing due to timed out get outlook mail activities

In this case, the change happened on your local machine/mail provided.

  • Check if any security updates from Microsoft have been applied recently that may cause your encountered issue.
  • Check if your local IT didn’t apply recently any GPO.
  • Check if you modified the version of the last working process. It may be that you modified the project workflows or dependency versions.
  • Check internally if any applications or firewalls have been applied recently.
  • Check with your Mail Service provider if they changed/decommissioned your old credential type authentification and if they added new/removed software prerequisites for it.

i will check again if anything have changed from IT side.
from bot side nothing changed and the issue is happening for me and other team members.

i think i didn’t make it clear but it’s not totally failing but it works for like maximum set of 50 emails with 10 minutes timeout compared to up to maximum set of 800 emails with 5 min timeout

It may be that the Mail Server provider limited the top parameter. Try to process the emails in batches of 50 emails while keeping the same Timeout value.

Let us know if this worked.

well technically yes that would work and would be straight forward solution even we would have to edit that in 20+ different projects.

I was more concerned to find the issue rather than doing extra work around it

Hey Mohammad,

Do you still face this issue?

We have a new Mail.Activities version 1.19.0, can you let us know if you still face the issue?

As well, you’ve mentioned that SMTP Send Email doesn’t work since 1.9.0 can you give us more details on that so, we can investigate?

Thank you,