Get outlook mail messages activity not working after UiPath Studio update

Has anyone else encountered issues with workflows that utilize the ‘Get outlook mail messages’ activity? I have a workflow that I run every day, but it stopped working properly as soon as I updated Studio to the newest version.

The error reads, “Source: Get outlook mail messages
Message: The operation has timed out.
Exception Type: System.TimeoutException”

Do I need to start using the ‘Get exchange mail messages’ activity now? I think I remember reading something about that at one point.

Any information would be very helpful. Thanks!

Hello @Ben88,

I have just done a test and in my case the “Get Outlook mail messages” works.

Can you provided us with more details about the error? Which version of the uipath.mail.activities are you using? Could you share your workflow?

Best Regards,


Try manually sending and receiving mail once, and try to run process.
Also check either it’s updating all folders or not in Outlook app.


Main Division Check FINAL new.xaml (19.3 KB)

Also, here is the error log:


Source: Get Outlook Mail Messages

Message: The operation has timed out.

Exception Type: System.TimeoutException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.TimeoutException: The operation has timed out.
at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)"

Have you tried updating your packages? Based on the XAML you attached, four of them are out of date.


I appreciate the reply. I tried updating the packages, but the activity is still timing out. I then removed the filter I had in the Get Outlook Mail Messages activity to test if maybe the newer version couldn’t read the filter for whatever reason, but it still did not work. I truly believe the update to the newer version of Studio has something to do with it.

hi we just encountered the same issue when running our bot we have 5 processes total and after each of them we wait for the SME’s email to with word “Proceed” in subject line.As our process is7-8 hours long first 4 of them executed fine, by the time we reached the 4th process at around 11 pm CST, bot was not reading the email messages. We tried to replicate the same activity on our system as well but the activity is not working for us.
Raised a ticket with UiPAth if you have found some solution please share. TEsting (1.8 KB)

Hi ,did you solve the problem?


Is your problem resolved now? If yes, please post the solution.

Purvi Singhal

Hello am also having the same issues sometimes it does not work if you people are using i3 you will get this issue or some times CPU is 100% on that time also it does not work try to open the outlook before running the program or just restart your system or don’t use outlook mail activity use SMTP or G-Suite activity if its help mark as a solution or if u get any other way please share me the solution its help us

Chethan P