Get Orchestrator Credential

Hi everyone! Im working on the Assignment1 but as when I did the UiDemo Exercises I can’t get the credentials from Orchestrator!

I dont know why when it comes the point where it should type in the username it types the value “admin” with its password in the password field. (I dont have any variable with the admin value)

Does anyone knows the solution? I’ve been looking on other similar question but couldnt find the answer as their solutions were that all the assets name need to mach. something that i have already checked

something that i have noticed is that in the value of the assets there is not a username while i saw that the other people with a similar problem have “username: username value”

so Im thinking that maybe it doesnt even store the credentials


Have you provided proper credentials in Orchestrator Assets ?

Provide the correct username and password in orchestrator asset.

The credential that I use for acme are the same I use to access to UiPath Academy

I use the same credential I provide to access to UiPath Academy


Please check once whether you have saved credentials in Windows credential manager or not ?

If yes then delete it and then try once.


I have just checked and now I see where it takes the value ‘admin’ from, when I run the project… but why?
Is it normal that these credentials are here?
and why doesn’t it take the credential with the right name (in this case System1_Credential)?


In both projects, you used same Asset name in_Credential. That’s why it took same credentials. Delete this one and then try. It should work fine.

In the latest version it will show as “In Credential Store”, in get credential activity provide asset name as “System1_Credential”, then you will get username as “String” and Password as “Secure string”…
Before doing all that check if robot is connected to orchestrator or not ???..


If you are trying to retrieve credentials from Orchestrator Assets then that robot machine should connect to Orchestrator.

If you are trying to retrieve credentials from windows credential manager then no need to connect to Orchestrator.

I actually didn’t use the in_Credential asset as a name. as you can see In the picture I posted I used System1_Credential. (Both in Orchestrator and Config file).
so my question are:
-why is taking a different credential?
-what I wanted to do is get the credential from orchestrator, but it take the credential from windows manager, why?

btw I just deleted both credential in windows credential manager and it worked, thanks.

1 Like

I think it is connected. how can I verify it?


Glad to help you.

Could you help me find out the answer of the 2 questions? Thanks in advance!

1 Like


I guess you are using REFramework right.

Please check Get App Credentials workflow arguments once in both processes and provide me screenshot. Will check and update you.

Get App Credentials workflow is enclosed in Try Catch block. It will try to retrieve the credentials from Orchestrator assets first. If it is found then it will retrieve and enter there. If any error occur then it will try to retrieve it from windows credential manager else it will ask to enter credentials. In you case, Robot got failed to retrieve credentials from orchestrator and may be because of that its getting credentials from Windows credential manager.

Its getting failed because of one of the below issues.

  1. Your BOT did not connect to Orchestrator.
  2. You wrongly mention Asset name in config file or in workflow.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.