Crdential Store in Assets in UI Orchestrator

Can anyone help me out How can I store my credential in Assets in Orchestrator. please check I am attaching a snapshot over here.

Hello @sainath2172

1 - Asset name, you give you the name of your asset
2 - Type, what will be your asset, credentials or variable, etc
3 - Description, if necessary to explain what you did there, like my credentials for ACME
4 - Credential Store, since you use the orchestrator platform, your data will be stored there
5 - Username, as login of the application you want to log in
6 - Password, as the password to access that application

After that, you will need to use get assets activity, to get your credentials from the orchestrator.

1 Like

The same process I followed but instead of using asset activity I just configured the asset in the config file and then In the workflow, I have created arguments here I called those values as shown in the snapshot.

Suggest me if I have taken the wrong move action. @mz3bel

@sainath2172

Yes, it’s better to use a config file! So are you still facing the issue ?

Yes URL is working fine but it was unable to take credentials. @mz3bel

@sainath2172

You mean get credentials from orchestrator ? Check your arguements, direction and asset names. In both config and and your worklow.

1 Like

Hi @sainath2172,

mention the credentials variable in Settings sheet of Config file, it will work.
Kudos!

1 Like

Yes, Credentials from the orchestrator. I have checked in both config and Workflow.may be the issue is in this workflow I was unable to debug it.


Can you please brief what is the issue. @mz3bel

@sainath2172

Please share your project so i can check what the issue

HI please find the project zip file.RoboticEnterpriseFramework practice.zip (998.6 KB) @mz3bel

@sainath2172, I believe you have mentioned wrong AssetName in Get Credential activity. It should match with the name in Orchestrator which is ACME_Credential in your case as per your first screenshot.

I had given same asset name which in Orchestrator in get credential,So it’s not working yet, too @Bhavik_Solanki

@sainath2172,
Aha, I just notice that there is problem with your config file. Open Config.xlsx file and remove extra space from ACME_Credential value.

I have just given underscore due to that it was taking space over there. @Bhavik_Solanki

@sainath2172, There is space after last character in value, so replace "ACME_Credential " with “ACME_Credential” and it should work. :slight_smile:

I have created an argument and then I called that argument value in the get credential activity.Finally solved. Thank you

1 Like

Good to know, sorry was busy couldn’t respond! Best of luck!

Its Not a problem Thank You @mz3bel

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.