Credential assets retrieving

I’m trying to retrieve username and password from a credential asset I previously created on Orchestrator. I think I’m missing something because when I run the process the robot isn’t able to obtain username and pass data in order to write them in the input fields. May anyone explain to me what are the required steps to succeed in this task?

You should use

Also, make sure the robot is connected to orchestrator.

1 Like

Ho, use ‘Get credentials’ activity
Create 2 variables
Var1- string - for username
Var2 - securestring - for password
In the get credential activity properties give correct asset name ( beware of case sensitive and spaces in asset name)
In the user name property give variable Var1
In the password property give variable Var2
Now you might be passing these variables into another workflow
In the invoke workflow file activity map the arguments of invoked workflow with these variables

Thank you,
I should have done as you explained, but it doesn’t work. I attach some screenshots.


1 Like

Kindly enable SIMULATE TYPE property in the property panel of Type into activity and try once

Make sure that the key is mention led correctly in the dictionary variable in_config as per the Name column in Excel file ( config file ) we have
Make sure that the asset name is mentioned correctly in the Get Credentials activity
Make sure your machine is connected to orchestrator


may I know what error we are getting in exact
To know that kindly run in debug mode so that we could find which activity is throwing error if any

Cheers @Clara_Silvestri


Thank you! I solved the problem and finally got logged in!

Cheers @Clara_Silvestri

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.