Focus on second window and do some operations on it (desktop application)

Hi everyone,
I’ma automating a desktop application and after clicking on certain butoon an other window appears and i have to click on a button on this window .
I tried many activities such as Find element , On element appear , on Image appear , click image but nothing works.

And now i’m trying to put attach window in get active window but also it didn’t work.
Please could you check with me the the editor selectors perhaps i did sthg wrong.
Here is a captures from my robot:

PS: i tried to use each activity alone but also it didn’t work :disappointed:

Hi @enchirah_maatki,

Use keyboard tab key to move to the button and send hotkey “enter” to do the click event

Hello @enchirah_maatki,

I guess you could use Set Focus activity when your second window pops up after you click a button.


thank’s @SamanGuruge for your answer but i really didn’t undrestand well the concept of this activity.
Is there any chance you explain it more or give me an example?

thank’s @Pankaj.Patil , i did try it but also it doesn’t work.

Oh I see,

Whatever you have used like attach window, get active window and set focus must resolve your problem.

Last I could suggest you that, try to make a selector using uiexplorer and debug the code.


Hi @enchirah_maatki,

I hope you’re not recorded the sequence.

After clicked the button, use the Find element or Element exists activitiy with the full selector(with the window name) and then try to click(full selector).

If not work plz share your both windows selector.


Hi @Michael_Udhaya
Thank’s for your answer.I did what you told but still nothing works.
Here’s a picture from my robot:

In this try i used Element exists and the Click and if i try to open the selector window it appears an other window that i don’t get:.
Could you please help with it?

Hi @enchirah_maatki

Don’t use attach window for both case.

Try all with full selector.


Hi @Michael_Udhaya, i used Element exists not attach window in this try.
And i didn’t get what you mean with "Try all with full selector ".
Sorry if i bothered you but could you explain maore?

Hey guys, @Pankaj.Patil, @Michael_Udhaya, @SamanGuruge
i have a guess why all thoose activities didn’t works.
I noticed that when the robot open that window, it appears like it is inactive (kind of grayed window) .In the mean while when i use a selector (of any activity) to indicate it, it’s active.
I don’t know if this is the problem but i thought that this may confuse it.
I tried to take a shot when it’s inactive but there’s no chance.
I figure that i could use Move cursor activity and then click directly on it (the window)
but i didn’t find it in the activities panel.
Could you help to solve it?

Good morning guys,
I finally managed to solve it.
My guess is right, the problem is the inactive window.
To solve it, i used Double click on the button that open that window, this way it opens and appears active and then i used Activate activity to continue my opertaions.
Thank’s for your help :blush:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.