Issue entering the value to pop up window

I am working on the ui automation, wherein i need to enter the value to webpage and i am stuck at one place, where i need to use “click” activity which basically opens the pop up page, on which i need to enter details, but as soon as i clicked, the pop up window gets opened, but after that it gives an error, cannot find the ui element to the selector. I tried with type into activity, i also tried with attach browser and attach window activity,but no result, can somebody tell me what is going wrong here?

Make sure that click activity is used with a ATTACH window activity and simulate click property of the click activity is enabled in the property panel or click activity
If
Use send hot key activity with key as tab that will get us to the field or button we want to reach
Use n number of send hot key with key as tab until we get to that button
Once after reaching use another send hot key activity with key as enter

It’s more like using keyboard without mouse, to navigate

Cheers @Rajesh_Acharya

1 Like

Few doubts over what u said.
1)what you mean by click activity is used with attach window activity
= I am using attach window activity right after click activity, is this right and is this what you mean ?
2)Since it is stuck at the place where attach window activity itself, will it run hotkey, since it comes after attach window.

Yah that’s what I meant

Yah it would work
Try manually once like how many tab key is required to get to that field and use that numbers of send hot key activity with tab key
Finally use a enter key with send hot key activity

Cheers @Rajesh_Acharya

1 Like

Still the issue is persisting. can you pls check my flow.

may i know why we use alt key
tab will be usually right to navigate across fields
@Rajesh_Acharya

1 Like

Yea that was typo… i change it to tab, and still getting the error.

Fine
there are two options…
–as it looks like browser level use attach browser and place these sendhot key and type into activity in it (remove the selector in type into activity as we are using sendhotkey)

or

–without this attach browser try only with these activities that include sendhotkey and type into activity (remove the selector in type into activity as we are using sendhotkey)

Cheers @Rajesh_Acharya

1 Like

sure…it worked once…and happily went to lunch…when i come back it seems like not working…anyway let me try the way u suggested…

may i know what is the issue you are getting now
@Rajesh_Acharya

Issue is solved now, it was becs of the selector, when the selector is like this


it works
if it is other than this, it was not able to find the ui element.
thank u so much for all ur tips

Cheers @Rajesh_Acharya

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.