Filter data table : data table

i am working on the calculate client hash assignemnet and i do not even know what that error means can anyone plz help

thank all of u but i solved it it turned out my mapping was wrong

Does your datatable have data in it?

yea it does

But it doesn’t. Look in the Locals panel on the left. It says NULL.

that is wierd cuz it supposed to go and collect all the clients then filter them how can i fix that

First you need to make sure you’ve got the arguments in your Invoke Code activities mapped properly.

If you do, then you need to troubleshoot the steps that populate the datatable.

it should be mapped propely as u can see i set the argument = to the data table i wanan filter

You have that set to “In” when it should be “In/Out”

Can you please Change the operation “=” Change to “Contains”

Hello @yahia1112

Please try with only one filter and check whether you are getting some data.
Then try to add more conditions to the Filter datatable activity.

Make sure in the datatable you have data with Type “WI5” and Status as “Open” .


Hello @yahia1112

Make sure the direction of your argument is mapped correctly.

And your data table contains the exact columns. You can also use “Contains” on the operation if the “=” is not working in the Filter Wizard.

yea i know it exist i checked so many times

i changed it and replaced = with contains and still had the same error

Pls check something:

  1. The column name… It can include whitespace or the second blank line inside
  2. The Argument In/Out
  3. Before filter… Use Output Datatable Activity + Writeline or MessageBox to print it into screen to check.